summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-06-24 12:14:23 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-27 00:59:47 +0200
commit93067368d753c17cb53753cf559d9181cbfe98b7 (patch)
treea85cc289ed0170aa7e72723debd2d6d37bfb3e39 /app-admin
parentapp-admin/mongo-tools: bump to 4.0.19 (diff)
downloadgentoo-93067368d753c17cb53753cf559d9181cbfe98b7.tar.gz
gentoo-93067368d753c17cb53753cf559d9181cbfe98b7.tar.bz2
gentoo-93067368d753c17cb53753cf559d9181cbfe98b7.zip
app-admin/mongo-tools: bump to 4.2.8
Package-Manager: Portage-2.3.102, Repoman-2.3.23 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-4.2.8.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index db48d55649c3..d5da4ec003ed 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -5,3 +5,4 @@ DIST mongo-tools-4.0.16.tar.gz 11139827 BLAKE2B 550acfd7e4434b178170dfd94c65668c
DIST mongo-tools-4.0.19.tar.gz 11139649 BLAKE2B 7e730138fce671e18a0ebe929b98eff1c0ce2c364ceef7d6868c380242689411c545ac321aebd609dcfe9f8d5b7d35cf37973a978f35a50cc44902b2dbad7134 SHA512 2639cb27a5a27e405bddf9817f409af244d643a9091f7e5ddff4876966af55b6710b0fe158c351df9aea10f3da0b87d224bfb2c962f4ca2cfe41f804cb16749c
DIST mongo-tools-4.2.3.tar.gz 15020325 BLAKE2B 8501a3ec6e947112ec561ce62f2ea568984f8ac911a7aff3cb8c08c1f29d2cfc64cf7f4b6a24ba73ae0f9b2b5853480f4fbed51c98fdc8c83cd433ea65e21dba SHA512 772719b450f8b656c22ac0126fee1e0fa58b5320c94ac6414b1d9af13e6437393c2482f2e386f4a73c84a2d1bfe0ea88df117a6a7ae87f4884477505cf662585
DIST mongo-tools-4.2.6.tar.gz 15016596 BLAKE2B 5ee37bf21ea05ec5ba2764c935c1dd3632753e772a01f854dc8a9949620e9a41fe95ba658a0efae0332ed2c059561e39e681f672cf5f4302a7f92c364cfab4b6 SHA512 e91bfba4b015f80d35b6c2ca766c599c5eedea113d6415ec0aef433d46b5e5fe06956481a063e26908a45fdcee4002125ea01a29fa3ea9a541a9210d25625f8e
+DIST mongo-tools-4.2.8.tar.gz 15021497 BLAKE2B e066c299462167754e0752079f35fef25b387eb1df0631ff0e0b783a8a14c4b68c6ed126ec3429f63de87b87b9fdde6a2645badd53ac1386befc7175a61a999e SHA512 c0fca14c60e5f399934f4dfad5be832684d2c1a1145967a4c395b246774f73f71e506bff902a634b7f08f7133304c09f14eb56a1a6fc8585608f537e59d9c899
diff --git a/app-admin/mongo-tools/mongo-tools-4.2.8.ebuild b/app-admin/mongo-tools/mongo-tools-4.2.8.ebuild
new file mode 100644
index 000000000000..7d8cc9a0ebc2
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-4.2.8.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="sasl ssl"
+
+DEPEND="dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+EGO_PN="github.com/mongodb/mongo-tools"
+S="${WORKDIR}/src/${EGO_PN}"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv ${MY_P} "${S}" || die
+}
+
+src_prepare() {
+ default
+
+ # allow building with go 1.12 #678924
+ sed -i 's/_Ctype_struct_/C.struct_/' vendor/github.com/google/gopacket/pcap/pcap.go || die
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ # build pie to avoid text relocations wrt #582854
+ local buildmode="pie"
+
+ # skip on ppc64 wrt #610984
+ if use ppc64; then
+ buildmode="default"
+ fi
+
+ mkdir -p bin || die
+ for i in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongoreplay; do
+ echo "Building $i"
+ GOROOT="$(go env GOROOT)" GOPATH="${WORKDIR}" go build -buildmode="${buildmode}" -o "bin/$i" \
+ -ldflags "-X ${EGO_PN}/common/options.VersionStr=${PV}" --tags "${myconf[*]}" "$i/main/$i.go" || die
+ done
+}
+
+src_install() {
+ dobin bin/*
+}