summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-17 13:59:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-22 14:07:23 +0100
commitc581a15c5ea12c7160969b8ba7065e2c5bf463a2 (patch)
treeded7b8ab2ec8a56bc86009f42fbc8e055bd2dccf /app-admin
parentdev-libs/libexplain: add missing defines. (diff)
downloadgentoo-c581a15c5ea12c7160969b8ba7065e2c5bf463a2.tar.gz
gentoo-c581a15c5ea12c7160969b8ba7065e2c5bf463a2.tar.bz2
gentoo-c581a15c5ea12c7160969b8ba7065e2c5bf463a2.zip
app-admin/testdisk: Add 7.1_pre20180322 Qt5-based snapshot
Bug: https://bugs.gentoo.org/639974 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/testdisk/Manifest1
-rw-r--r--app-admin/testdisk/testdisk-7.1_pre20180322.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-admin/testdisk/Manifest b/app-admin/testdisk/Manifest
index aaf4fce8fb0e..5a9d30a35294 100644
--- a/app-admin/testdisk/Manifest
+++ b/app-admin/testdisk/Manifest
@@ -1 +1,2 @@
DIST testdisk-7.0.tar.bz2 676990 BLAKE2B deeeee290f05d4a992ff69c990cca8480c74e67ba2df0b523640833b968ed98dc9f44e5f33b2666daf07286dd8349b98171d6c65f7f3baae3d5cca159a5c9584 SHA512 b1ebe1d2fca453660a17623b70c06e0195cb5f07056fb7bc683d575c034fb71dfb793582c804dcff0ca57789a6de84bbf13b1a554353811660996e42199102e2
+DIST testdisk-7.1_pre20180322.tar.gz 632598 BLAKE2B 741610622c9afa2c41d14e8eb391cbe629a5f7ac102cf4cbf446b0c0d7330cb8482a17c1ce8470aa9d1b0578aac254cf17aa061e21dd831a803152514fab5422 SHA512 fbe699ccfbe31be636d71eda5d1fccb8efb16788bf664e048ee16344c3d3689961aaa7ef4c9123690db695bb7ae3439440bd775ab8b8455500232b2fc6048ebc
diff --git a/app-admin/testdisk/testdisk-7.1_pre20180322.ebuild b/app-admin/testdisk/testdisk-7.1_pre20180322.ebuild
new file mode 100644
index 000000000000..7ea7b9df550d
--- /dev/null
+++ b/app-admin/testdisk/testdisk-7.1_pre20180322.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+COMMIT=9eb2aa12ce051d8d3d31e6b440389d5abf5efaf1
+inherit autotools-utils flag-o-matic
+
+DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
+HOMEPAGE="https://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="https://git.cgsecurity.org/cgit/${PN}/snapshot/${PN}-${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="ewf jpeg ntfs qt5 reiserfs static zlib"
+
+REQUIRED_USE="static? ( !qt5 )"
+
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+COMMON_DEPEND="
+ static? (
+ sys-apps/util-linux[static-libs]
+ sys-fs/e2fsprogs[static-libs]
+ sys-libs/ncurses:0[static-libs]
+ jpeg? ( virtual/jpeg:0[static-libs] )
+ ntfs? ( sys-fs/ntfs3g[static-libs] )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8[static-libs] )
+ zlib? ( sys-libs/zlib[static-libs] )
+ !arm? ( ewf? ( app-forensics/libewf:=[static-libs] ) )
+ )
+ !static? (
+ sys-apps/util-linux
+ sys-fs/e2fsprogs
+ sys-libs/ncurses:0=
+ jpeg? ( virtual/jpeg:0 )
+ ntfs? ( sys-fs/ntfs3g )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ zlib? ( sys-libs/zlib )
+ !arm? ( ewf? ( app-forensics/libewf:= ) )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+RDEPEND="!static? ( ${COMMON_DEPEND} )"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+DOCS=( )
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_configure() {
+ local myeconfargs=(
+ --enable-sudo
+ --docdir="${ROOT}/usr/share/doc/${P}"
+ $(use_with ewf)
+ $(use_with jpeg)
+ $(use_with ntfs)
+ $(use_with ntfs ntfs3g)
+ $(use_enable qt5 qt)
+ $(use_with reiserfs)
+ $(use_with zlib)
+ )
+
+ # this static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ econf "${myeconfargs[@]}"
+
+ # perform safety checks for NTFS, REISERFS and JPEG
+ if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
+ die "Failed to find either NTFS or NTFS-3G library."
+ fi
+ if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+}