summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2018-06-27 18:41:41 -0500
committerWilliam Hubbs <williamh@gentoo.org>2018-06-27 19:12:48 -0500
commitc7892c22f05d4d1bddf5d310e78f03dfb858ac6b (patch)
tree8928beed8f5c743cc311334dfa10fc01f2c945f1 /app-admin
parentmedia-gfx/graphicsmagick: version bump to 1.3.30 (diff)
downloadgentoo-c7892c22f05d4d1bddf5d310e78f03dfb858ac6b.tar.gz
gentoo-c7892c22f05d4d1bddf5d310e78f03dfb858ac6b.tar.bz2
gentoo-c7892c22f05d4d1bddf5d310e78f03dfb858ac6b.zip
app-admin/fluentd: 1.2.2 bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/fluentd/Manifest1
-rw-r--r--app-admin/fluentd/files/fluentd.initd7
-rw-r--r--app-admin/fluentd/fluentd-1.2.2.ebuild54
3 files changed, 59 insertions, 3 deletions
diff --git a/app-admin/fluentd/Manifest b/app-admin/fluentd/Manifest
index ab8700ec226f..a20e953296e8 100644
--- a/app-admin/fluentd/Manifest
+++ b/app-admin/fluentd/Manifest
@@ -1,2 +1,3 @@
DIST fluentd-1.1.3.gem 413184 BLAKE2B facda41a26f9fe4f55a4ae6f97336acaa818534b6ac8740badcb132a18497e8767723e931bb2506843b56208deaf41cdaf9ac81821618cb223b8035527d355d7 SHA512 0d17668c06e515219a39ddc7ecda6b5ec5d29e7d4d3799e3447034ad731568d870ac3d36d468be21b6ef7a4198353c3045872902c41a54c0c2eacad8ec12f357
DIST fluentd-1.2.0.gem 430592 BLAKE2B 698666a5c1dfc3f90b6b1f5b9e58070b71caef859f5d41472185a6f9f1d1d2b1c3631ca0ad01fbac4b4f333484a539aedc70a90a4381fef90c5c4130ffd61b61 SHA512 928ad81381c024efa2ad1e5b0f3d3a74f4bf8e3373c8f835925e89739c6536048a8a16e6b59accf4719192118b86b2fb49b3e9536611381a8a236997fcc96651
+DIST fluentd-1.2.2.gem 431616 BLAKE2B 854f23908f10d0bbae1a48392f439ce33e1e3619eb887235b2018bc30166faec8c40d05b9fc1b4aac44befd7afea87b3547a7d458c6e471bde65616e92f41951 SHA512 2a582bfd54f290612cdfee5e3ff9e5adc894bc02639991ccfd551c90070167837288d33fecf1e4975165b6f6758d124ff0b0fed715c9276ef9def566057d9e57
diff --git a/app-admin/fluentd/files/fluentd.initd b/app-admin/fluentd/files/fluentd.initd
index ecbd10e0622a..b2e39d55f60e 100644
--- a/app-admin/fluentd/files/fluentd.initd
+++ b/app-admin/fluentd/files/fluentd.initd
@@ -3,11 +3,12 @@
# Distributed under the terms of the GNU General Public License v2
command=/usr/bin/fluentd
+logfile=/var/log/fluentd/fluent.log
pidfile=/var/run/fluentd.pid
-command_args="--daemon ${pidfile} --no-supervisor ${fluent_opts}"
+command_args="--daemon ${pidfile} --no-supervisor -o ${logfile} ${fluentd_opts}"
command_background=yes
command_user=fluentd:fluentd
-
+
start_pre() {
-fluentd -q --dry-run
+ fluentd -q --dry-run
}
diff --git a/app-admin/fluentd/fluentd-1.2.2.ebuild b/app-admin/fluentd/fluentd-1.2.2.ebuild
new file mode 100644
index 000000000000..5394c440e799
--- /dev/null
+++ b/app-admin/fluentd/fluentd-1.2.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+inherit ruby-fakegem user
+
+DESCRIPTION="data collector and unified logging layer (project under CNCF)"
+HOMEPAGE="https://www.fluentd.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+ruby_add_rdepend "
+ >=dev-ruby/msgpack-0.7.0
+ >=dev-ruby/yajl-ruby-1.0
+ >=dev-ruby/coolio-1.4.5
+ >=dev-ruby/serverengine-2.0.4
+ >=dev-ruby/http_parser_rb-0.5.1
+ >=dev-ruby/sigdump-0.2.2
+ >=dev-ruby/tzinfo-1.0
+ >=dev-ruby/strptime-0.2.2"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/tzinfo-data/d' \
+ -e '/dig_rb/d' \
+ "${PN}".gemspec || die "'sed failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+ keepdir /var/log/fluentd
+ fowners fluentd:adm /var/log/fluentd
+ insinto /etc/fluent
+ doins "${FILESDIR}"/fluent.conf
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "A default configuration file has been installed in"
+ elog "${EROOT}etc/fluent/fluent.conf. You will need to edit"
+ elog "this file to match your configuration."
+ fi
+}