summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-07-22 16:57:19 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-07-22 16:58:46 -0500
commitea518db8669319c1737844ab5f2f5bef3bbd234a (patch)
treeda6747dc707c7a4aec993ff007a488b8497e7562 /app-admin
parentapp-admin/ansible-base: 2.11.3 bump (diff)
downloadgentoo-ea518db8669319c1737844ab5f2f5bef3bbd234a.tar.gz
gentoo-ea518db8669319c1737844ab5f2f5bef3bbd234a.tar.bz2
gentoo-ea518db8669319c1737844ab5f2f5bef3bbd234a.zip
app-admin/ansible: 4.3.0 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-4.3.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 488ecafb4fab..617dc2e82e72 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,2 +1,3 @@
DIST ansible-2.10.7.tar.gz 29862966 BLAKE2B fa86deaac034adc8e02f91cbf4b63ca718d50376cab19e156c85f8372c1787275e2ce24840fc3cbad2b9191146c785feafcf024a0c14052ee39a839390cc1319 SHA512 7a6522bcc57c178c9c6e87e313f6f175d5c74ac0d1b9dd0cad5506c7fa0efb16d4a627dc2d9c73f988177544bd9ccfdbec162d0feacc757edeb20280d7414191
DIST ansible-4.1.0.tar.gz 33999079 BLAKE2B b7c512ed01f220dbfdd5c90cd67c88cc3b50dce5a83a783b798afafe88d75d96ae7abd9a512a1d4fc4e1ad0305c72e6d2b4ebe3811addf78faf2d14dab7dd188 SHA512 603a5aa6b63d447efcb6e2f04f40c1bf5d7cc888f344bdc00ca3f9bca92c406554328a0e77cf3d5f2633addc9d6459d7b9d9176d14ecc506c67013fc8180b0c0
+DIST ansible-4.3.0.tar.gz 35135987 BLAKE2B 6f4bf55f07275b7264a7fba693816bf925d574d4da3d4d13af9b85c44d4b5adf9e823b9bd936408a0e424273f8f2aa529e960105842444d26eb3f45973109ec5 SHA512 035a236d0762e425c4ce4ffd709386075aee438bb8085a25920543bb2378feb07fb8f0a50ce9fb6b0d1f5dde1f27a408b828c286bfc1173d38da5f8c7b572c3a
diff --git a/app-admin/ansible/ansible-4.3.0.ebuild b/app-admin/ansible/ansible-4.3.0.ebuild
new file mode 100644
index 000000000000..45a02aba0ec9
--- /dev/null
+++ b/app-admin/ansible/ansible-4.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-base-2.11.1
+ <app-admin/ansible-base-2.12"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}