summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-02-23 16:57:00 +0100
committerPacho Ramos <pacho@gentoo.org>2019-02-23 16:59:20 +0100
commitedb2de817b7aa84c5d4c1731d3cce3b7c2fd185d (patch)
tree1bed2f888c0789e52f9c2e27ef12467c303893f2 /app-admin
parentdev-libs/libreport: Version bump to 2.10.0 (diff)
downloadgentoo-edb2de817b7aa84c5d4c1731d3cce3b7c2fd185d.tar.gz
gentoo-edb2de817b7aa84c5d4c1731d3cce3b7c2fd185d.tar.bz2
gentoo-edb2de817b7aa84c5d4c1731d3cce3b7c2fd185d.zip
app-admin/abrt: Version bump to 2.12.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/abrt/Manifest1
-rw-r--r--app-admin/abrt/abrt-2.12.0.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/app-admin/abrt/Manifest b/app-admin/abrt/Manifest
index 1976544afdb1..11781cedb08b 100644
--- a/app-admin/abrt/Manifest
+++ b/app-admin/abrt/Manifest
@@ -1,2 +1,3 @@
DIST abrt-2.0.12.tar.gz 1090121 BLAKE2B 272f486bd166a33fea3e340763b3443b5643a650fe16ad326e249309c355f214c67937456dd2d8f3e7cdac65cb85bd8030e6b89671f427085a05dca64b8f874d SHA512 5432205edb4483fb1883b9bcebab48784b16dd9e72c3a929ea0d50c48dab638d80f136b6b0d7648d8ec9fcb79d5ce8c1be37d36301d3b2b151868901be82a63a
DIST abrt-2.10.10.tar.gz 6830586 BLAKE2B 5cd45144678e6355cb1362c3ebe5531104bb150ff95c42d10e3056f7619cdc7dc3da57e4025cab05234866a4634f29bc07fd78f574800d6b303385c6befa25bd SHA512 6daeea898c9328d31b952ef12202162e002f91b4115301e5d66a0e6991251f9a8322b87201128f7efd54b42b76cb94abc4cf01e5d5b563f254f6757ec7e2127d
+DIST abrt-2.12.0.tar.gz 6799338 BLAKE2B 57a9b3fac4a4a5f55630be0573b26d4ae2d921d4f09d6566339a77f314c413c1a9e242f882fe20befabf30a58e7df21395edcf1b0d560bfeadf8e854bff6a705 SHA512 3567332399cd9708505a6d05c9388c7da5c14c7432e6fd40e5e76b6bcea8859c17b3b6c52a96ce54740e3682d75d8bf77dbc5fede80bd4fc6f72c60014f9cded
diff --git a/app-admin/abrt/abrt-2.12.0.ebuild b/app-admin/abrt/abrt-2.12.0.ebuild
new file mode 100644
index 000000000000..a8ed0ff492d4
--- /dev/null
+++ b/app-admin/abrt/abrt-2.12.0.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools gnome2-utils python-single-r1 systemd user
+
+DESCRIPTION="Automatic bug detection and reporting tool"
+HOMEPAGE="https://github.com/abrt/abrt/wiki/ABRT-Project"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug selinux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.43.4:2
+ >=dev-libs/libreport-2.10.0[python]
+ dev-libs/libxml2:2
+ >=gnome-base/gsettings-desktop-schemas-3.15.1
+ net-libs/libsoup:2.4
+ sys-apps/dbus
+ sys-apps/systemd:0=
+ sys-auth/polkit
+ sys-fs/inotify-tools
+ x11-libs/gtk+:3
+"
+RDEPEND="${COMMON_DEPEND}
+ app-arch/cpio
+ app-arch/rpm
+ dev-libs/elfutils
+ dev-libs/json-c:0=
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+ >=sys-devel/gdb-7
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ dev-libs/satyr[${PYTHON_USEDEP}]
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17
+"
+
+RESTRICT="test" # tests *may* be broken due to all the RHEL crap. explore later.
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ enewgroup abrt
+ enewuser abrt -1 -1 -1 abrt
+}
+
+src_prepare() {
+ default
+
+ # Install under proper directory
+ sed -i -e 's:dbusabrtdocdir = ${datadir}/doc/abrt-dbus-${VERSION}/html:dbusabrtdocdir = ${datadir}/doc/${PF}/html:' doc/problems-service/Makefile.am || die
+
+ # pyhook test is sensitive to the format of python's error messages, and
+ # fails with certain python versions
+ sed -e '/pyhook.at/ d' \
+ -i tests/Makefile.* tests/testsuite.at || die "sed remove pyhook tests failed"
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+}
+
+src_configure() {
+ myeconfargs=(
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --localstatedir="${EPREFIX}/var"
+ --without-bodhi
+ # package breaks due to not finding libreport-web with bodhi plugin enabled
+ --without-rpm
+ $(usex selinux "" "--without-selinux")
+ --without-python2
+ # Fixes "syntax error in VERSION script" and we aren't supporting Python2 anyway
+ --with-python3
+ --without-pythondoc
+ # package breaks due to no sphinx-build-3
+ --without-pythontests
+ # kill tests for now until they can be explored.
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ python_optimize #661706
+
+ keepdir /var/run/abrt
+ # /var/spool/abrt is created by dev-libs/libreport
+
+ diropts -m 700 -o abrt -g abrt
+ keepdir /var/spool/abrt-upload
+
+ diropts -m 775 -o abrt -g abrt
+ keepdir /var/cache/abrt-di
+
+ find "${D}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}/${PN}-2.0.12-r1-init" abrt
+ newconfd "${FILESDIR}/${PN}-2.0.12-r1-conf" abrt
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}