summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-02 18:28:09 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-02 18:28:09 +0300
commitffc8621fc9f0ffa10a71ed5b11074a34dcd03f98 (patch)
tree2b1dce2ce2622201bfd5d13e4c0ffb86f6ebe930 /app-admin
parentdev-python/boto3: add 1.24.65 (diff)
downloadgentoo-ffc8621fc9f0ffa10a71ed5b11074a34dcd03f98.tar.gz
gentoo-ffc8621fc9f0ffa10a71ed5b11074a34dcd03f98.tar.bz2
gentoo-ffc8621fc9f0ffa10a71ed5b11074a34dcd03f98.zip
app-admin/awscli: add 1.25.66
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.66.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 464619a12820..21542bfe5fdb 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -2,3 +2,4 @@ DIST aws-cli-1.25.56.gh.tar.gz 2252989 BLAKE2B a082d42bd9ebaa858a3464bf885ba86a6
DIST aws-cli-1.25.61.gh.tar.gz 2257977 BLAKE2B d1090ca3eb86284520e970a997932af31c250d2ca12ab7ddd2a64a55540e5b747bd30d21f4b0fdb8cd926692bde53a37b618f4cc2b9e92c7fcbca95419d7fb36 SHA512 cb869e08b9bec7c542d44401590f3ee5500564c23ff17d47e6a0265e1f98aea7429e55757e2184d7fbf23b3bb65366692040c059cdfffef39e1de2072345060c
DIST aws-cli-1.25.64.gh.tar.gz 2263441 BLAKE2B d68ef0a3dabba879d9d650a911d5f286116a6d407d9d958088f7b7cd54c27db3be28165a1676e949785056519477f315ca4e08f6df9938da2516974d026fef81 SHA512 4db256228dde6aed2432133373c045bf2f2e69a7764629f3d13a94e086f99b43cc2a29862e6f973742a0de08032e6c26499b230db81575eabd288c8f2f63eb0a
DIST aws-cli-1.25.65.gh.tar.gz 2263933 BLAKE2B 5c516e6a95a333073cf7200eff476e625e9b832b32b44fc41e3656c5c78710ba8272fdb5fbafcfe85fe17853c1f40e26fd6de84a6c4c42a7cd6d7d2ce41ab8f5 SHA512 7dcdd2d0e05000f09d41a24c8e14ee7b4623e89f027c193c67635296f568c8d1f383956c5c351c85b7c48150796203dce777ef2f6376c3778ea2ec8b8f39072b
+DIST aws-cli-1.25.66.gh.tar.gz 2264111 BLAKE2B 7aaa42d654a873fea44fe64e0805c240700830c653ecfbfab4bf8838ba2aca5ec9508241e9fd9329b546d098eb4c68f886dac1afc31e12cea4779cc35ec091fb SHA512 dcddfebf2051fad23208c2617596c6aa4462e940056f5963526983c15b6c33bb118a769f139a8c8297d413e9a6ae129d7e14a6ffa56aa595dcde0128ea10d5c2
diff --git a/app-admin/awscli/awscli-1.25.66.ebuild b/app-admin/awscli/awscli-1.25.66.ebuild
new file mode 100644
index 000000000000..3d5bba5c1200
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.66.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# botocore is x.(y+2).(z-1)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 1 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}