summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 18:14:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 18:14:06 +0100
commit38cc525db6db66713207f49686e10ede64776d81 (patch)
tree65dedcfca9977ec372a6cc722f8afd2f94820f1d /app-arch/brotli
parentnet-libs/quiche: Switch back to cmake-utils.eclass (diff)
downloadgentoo-38cc525db6db66713207f49686e10ede64776d81.tar.gz
gentoo-38cc525db6db66713207f49686e10ede64776d81.tar.bz2
gentoo-38cc525db6db66713207f49686e10ede64776d81.zip
app-arch/brotli: Switch back to cmake-utils.eclass
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-arch/brotli')
-rw-r--r--app-arch/brotli/brotli-1.0.7.ebuild14
-rw-r--r--app-arch/brotli/brotli-9999.ebuild14
2 files changed, 14 insertions, 14 deletions
diff --git a/app-arch/brotli/brotli-1.0.7.ebuild b/app-arch/brotli/brotli-1.0.7.ebuild
index fec4aa455a73..dd0a67b6a931 100644
--- a/app-arch/brotli/brotli-1.0.7.ebuild
+++ b/app-arch/brotli/brotli-1.0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
DISTUTILS_OPTIONAL="1"
DISTUTILS_IN_SOURCE_BUILD="1"
-CMAKE_ECLASS=cmake
+
inherit cmake-multilib distutils-r1
DESCRIPTION="Generic-purpose lossless compression algorithm"
@@ -37,14 +37,14 @@ RESTRICT="!test? ( test )"
src_prepare() {
use python && distutils-r1_src_prepare
- cmake_src_prepare
+ cmake-utils_src_prepare
}
multilib_src_configure() {
local mycmakeargs=(
-DBUILD_TESTING="$(usex test)"
)
- cmake_src_configure
+ cmake-utils_src_configure
}
src_configure() {
cmake-multilib_src_configure
@@ -52,7 +52,7 @@ src_configure() {
}
multilib_src_compile() {
- cmake_src_compile
+ cmake-utils_src_compile
}
src_compile() {
cmake-multilib_src_compile
@@ -64,7 +64,7 @@ python_test(){
}
multilib_src_test() {
- cmake_src_test
+ cmake-utils_src_test
}
src_test() {
cmake-multilib_src_test
@@ -72,7 +72,7 @@ src_test() {
}
multilib_src_install() {
- cmake_src_install
+ cmake-utils_src_install
}
multilib_src_install_all() {
use python && distutils-r1_src_install
diff --git a/app-arch/brotli/brotli-9999.ebuild b/app-arch/brotli/brotli-9999.ebuild
index 26f80b64ecbd..8cc58bf02728 100644
--- a/app-arch/brotli/brotli-9999.ebuild
+++ b/app-arch/brotli/brotli-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
DISTUTILS_OPTIONAL="1"
DISTUTILS_IN_SOURCE_BUILD="1"
-CMAKE_ECLASS=cmake
+
inherit cmake-multilib distutils-r1
DESCRIPTION="Generic-purpose lossless compression algorithm"
@@ -37,14 +37,14 @@ RESTRICT="!test? ( test )"
src_prepare() {
use python && distutils-r1_src_prepare
- cmake_src_prepare
+ cmake-utils_src_prepare
}
multilib_src_configure() {
local mycmakeargs=(
-DBUILD_TESTING="$(usex test)"
)
- cmake_src_configure
+ cmake-utils_src_configure
}
src_configure() {
cmake-multilib_src_configure
@@ -52,7 +52,7 @@ src_configure() {
}
multilib_src_compile() {
- cmake_src_compile
+ cmake-utils_src_compile
}
src_compile() {
cmake-multilib_src_compile
@@ -64,7 +64,7 @@ python_test(){
}
multilib_src_test() {
- cmake_src_test
+ cmake-utils_src_test
}
src_test() {
cmake-multilib_src_test
@@ -72,7 +72,7 @@ src_test() {
}
multilib_src_install() {
- cmake_src_install
+ cmake-utils_src_install
}
multilib_src_install_all() {
use python && distutils-r1_src_install