summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-14 12:16:55 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-14 12:24:47 +0200
commita8ad024daf87101a1b286e7602a5641ee2fb9ece (patch)
tree1075eb908a7c7b8fd0dede0238699971cc9a1a7f /app-arch/file-roller
parentx11-misc/sisctrl: Configure for correct libdir (diff)
downloadgentoo-a8ad024daf87101a1b286e7602a5641ee2fb9ece.tar.gz
gentoo-a8ad024daf87101a1b286e7602a5641ee2fb9ece.tar.bz2
gentoo-a8ad024daf87101a1b286e7602a5641ee2fb9ece.zip
app-arch/file-roller: bump to 3.30.1
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-arch/file-roller')
-rw-r--r--app-arch/file-roller/Manifest1
-rw-r--r--app-arch/file-roller/file-roller-3.30.1.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index 9314d11e1d9a..2761fc25d027 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1,2 +1,3 @@
DIST file-roller-3.26.2.tar.xz 1436760 BLAKE2B a563f77dcc8d61e90e4e42fa4f08aded657d677b319b39f4c9fd16670a2309e81f142b7b8528e52db0be3f454efca15ccd7e9e25754a95b45800a9ca02969e12 SHA512 3572446081f931ce7cfd7eccdc9450d798164426a68bc332f9340b7c06b79ce4f1589b817c27322a0c1681d7f2cb8cf93462cde1e3df13ad40789faec1decc9f
DIST file-roller-3.28.1.tar.xz 1367876 BLAKE2B 7a33b1d329e76beb2999d0a701aa182b83442471eeacdca61bf50d417f3748f4985642239faa3227ff6665ce7b0c56a802b4536cda794950524688607526bb1b SHA512 5418282a91771f6b7a95ceca986c780472341ca81a6fffa169a593709121c7d4694076bf074a00e3cb7bff6df0cf9f2904cf462cca5d0fbadf6e8aafbb344a03
+DIST file-roller-3.30.1.tar.xz 1443340 BLAKE2B 352b094b51d342ac71f2174b59dff262ba46b4697c21164ba18bf825d70cb609d59a35ce0efe1013e217e86754822accc11c59eb9bba7185a9f7efe5dded4def SHA512 8f3f55cd7d6769fbf8f72118bb8982775c3f83534266db1f2cc9bbfd9e8dd68545ab49baaa4e468ce22e616346dec9c99c11a0c5b4208dca2e648fac8756cea7
diff --git a/app-arch/file-roller/file-roller-3.30.1.ebuild b/app-arch/file-roller/file-roller-3.30.1.ebuild
new file mode 100644
index 000000000000..63328057b6a6
--- /dev/null
+++ b/app-arch/file-roller/file-roller-3.30.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 xdg
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+IUSE="libnotify nautilus packagekit"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/json-glib-0.14
+ >=x11-libs/gtk+-3.13.2:3
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.4.3:= )
+ nautilus? ( >=gnome-base/nautilus-2.22.2 )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+lz4 - app-arch/lz4
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -v "${FILESDIR}"/3.22-packages.match data/packages.match || die
+
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Drun-in-place=false
+ $(meson_use nautilus nautilus-actions)
+ $(meson_use libnotify notification)
+ $(meson_use packagekit)
+ -Dlibarchive=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}