summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-04-17 12:37:09 +0200
committerPacho Ramos <pacho@gentoo.org>2016-04-17 13:13:28 +0200
commitff0f22cd530fca5e66e2b39ac14b5dd0138e030a (patch)
treea10914758428fb66df261b466de6388106c4d03e /app-arch/file-roller
parentapp-arch/file-roller: Drop old (diff)
downloadgentoo-ff0f22cd530fca5e66e2b39ac14b5dd0138e030a.tar.gz
gentoo-ff0f22cd530fca5e66e2b39ac14b5dd0138e030a.tar.bz2
gentoo-ff0f22cd530fca5e66e2b39ac14b5dd0138e030a.zip
app-arch/file-roller: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-arch/file-roller')
-rw-r--r--app-arch/file-roller/Manifest1
-rw-r--r--app-arch/file-roller/file-roller-3.16.5.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index 8c2650c31cd5..b5e56d7d4f5b 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1 +1,2 @@
DIST file-roller-3.16.4.tar.xz 1412224 SHA256 5455980b2c9c7eb063d2d65560ae7ab2e7f01b208ea3947e151680231c7a4185 SHA512 76378e16cd7f37a336b3eb3c6106cf36c2ea6e9209c23175810e2b80dc13a7b62b04cfcdea0b2bf69251baf7b164e85c34d99813cdbfd07433f73aba9c7361ae WHIRLPOOL 0d8736e13b97a4a005ae53bd9885b10c8a7797e10e0d8f4548e4112490ebc3ce91b0e5349b251bdca5d0f392318be7ea4fb324e3399300e362f47b024217849d
+DIST file-roller-3.16.5.tar.xz 1415236 SHA256 09a68db98aa33febdad76e6977d7771b3b444da7f57ab6f4fe7d6a77e39d5a91 SHA512 83c8dddb547f36faa2728996648479255353706a266ce26e79f8f6141794d0281a9817f2a1dc687623ba8382cab93aef23675e2f3ef6d4abb9f8871f253d2c2d WHIRLPOOL 01d54e45d9d8b81c5f965622adbacac1400f56461e230999e97aa1cde135714e7e80317749c04eac7b4a49fea0fa66142b9dfbec0876b743b4709d3d17c72cce
diff --git a/app-arch/file-roller/file-roller-3.16.5.ebuild b/app-arch/file-roller/file-roller-3.16.5.ebuild
new file mode 100644
index 000000000000..0005443af739
--- /dev/null
+++ b/app-arch/file-roller/file-roller-3.16.5.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 readme.gentoo-r1
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+IUSE="nautilus packagekit"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/json-glib-0.14
+ >=x11-libs/gtk+-3.13.2:3
+ >=x11-libs/libnotify-0.4.3:=
+ sys-apps/file
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ nautilus? ( >=gnome-base/nautilus-3 )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${RDEPEND}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.40.0
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -f "${FILESDIR}"/3.6.0-packages.match data/packages.match || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+ # --disable-debug because enabling it adds -O0 to CFLAGS
+ gnome2_src_configure \
+ --disable-run-in-place \
+ --disable-static \
+ --disable-debug \
+ --enable-magic \
+ --enable-libarchive \
+ $(use_enable nautilus nautilus-actions) \
+ $(use_enable packagekit)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}