summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-02 22:06:54 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-02 22:06:54 +0200
commitcf9efe3408bce9174fc3f7da0d7821f7f7368f30 (patch)
tree63372ebc3061ffbc369977aee7e70dc46404e24b /app-arch/funzix/funzix-1.0-r1.ebuild
parentapp-arch/bsdsfv: update EAPI 6 -> 8 (diff)
downloadgentoo-cf9efe3408bce9174fc3f7da0d7821f7f7368f30.tar.gz
gentoo-cf9efe3408bce9174fc3f7da0d7821f7f7368f30.tar.bz2
gentoo-cf9efe3408bce9174fc3f7da0d7821f7f7368f30.zip
app-arch/funzix: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-arch/funzix/funzix-1.0-r1.ebuild')
-rw-r--r--app-arch/funzix/funzix-1.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/funzix/funzix-1.0-r1.ebuild b/app-arch/funzix/funzix-1.0-r1.ebuild
new file mode 100644
index 000000000000..eae0ebd84376
--- /dev/null
+++ b/app-arch/funzix/funzix-1.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="unpacker for the bogus ZIX format"
+HOMEPAGE="http://funzix.sourceforge.net/"
+SRC_URI="mirror://sourceforge/funzix/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.0-fix-build-system.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin funzix
+ einstalldocs
+}