summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-04-22 13:44:18 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-23 10:51:20 +0200
commita730800dcc2a4b7a08e37ccdd5dfe47a43f43705 (patch)
treede11b3ab31fecfec7ff45263f6129f606aa6e850 /app-arch/ipkg-utils
parentx11-plugins/wmstickynotes: drop old (EAPI4) (diff)
downloadgentoo-a730800dcc2a4b7a08e37ccdd5dfe47a43f43705.tar.gz
gentoo-a730800dcc2a4b7a08e37ccdd5dfe47a43f43705.tar.bz2
gentoo-a730800dcc2a4b7a08e37ccdd5dfe47a43f43705.zip
app-arch/ipkg-utils: drop old (EAPI5)
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-arch/ipkg-utils')
-rw-r--r--app-arch/ipkg-utils/ipkg-utils-1.7.050831-r2.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/app-arch/ipkg-utils/ipkg-utils-1.7.050831-r2.ebuild b/app-arch/ipkg-utils/ipkg-utils-1.7.050831-r2.ebuild
deleted file mode 100644
index 4833a4dc6cfc..000000000000
--- a/app-arch/ipkg-utils/ipkg-utils-1.7.050831-r2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils toolchain-funcs versionator
-
-MY_P="${PN}-$(get_version_component_range 3)"
-
-DESCRIPTION="Tools for working with the ipkg binary package format"
-HOMEPAGE="http://www.openembedded.org/"
-SRC_URI="http://handhelds.org/download/packages/ipkg-utils/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
-IUSE="minimal"
-
-DEPEND="
- !minimal? (
- app-crypt/gnupg
- net-misc/curl
- )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-tar_call_fixes.patch"
- epatch "${FILESDIR}/${P}-hashlib.patch"
-
- sed '/python setup.py build/d' -i Makefile
-
- if use minimal; then
- elog "ipkg-upload is not installed when the \`minimal' USE flag is set. If you"
- elog "need ipkg-upload then rebuild this package without the \`minimal' USE flag."
- fi
-}
-
-src_compile() {
- distutils-r1_src_compile
- emake CC="$(tc-getCC)" || die "emake failed"
-}
-
-python_install() {
- distutils-r1_python_install
-
- if use minimal; then
- rm "${ED}usr/bin/ipkg-upload" \
- "${D}$(python_get_scriptdir)/ipkg-upload" || die
- fi
-}
-
-src_install() {
- distutils-r1_src_install
-}
-
-pkg_postinst() {
- elog "Consider installing sys-apps/fakeroot for use with the ipkg-build command,"
- elog "that makes it possible to build packages as a normal user."
-}