summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-28 16:04:51 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-28 16:07:24 +0100
commit44c2c7b3e4732cbcd4042c91134c1869477ccd76 (patch)
tree914156c0e887719fb7adec58a37b546c52f89d19 /app-arch/pure-sfv
parentapp-backup/vzdump: Port to EAPI 6 (diff)
downloadgentoo-44c2c7b3e4732cbcd4042c91134c1869477ccd76.tar.gz
gentoo-44c2c7b3e4732cbcd4042c91134c1869477ccd76.tar.bz2
gentoo-44c2c7b3e4732cbcd4042c91134c1869477ccd76.zip
app-arch/pure-sfv: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-arch/pure-sfv')
-rw-r--r--app-arch/pure-sfv/files/pure-sfv-0.3-asneeded.patch11
-rw-r--r--app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-system.patch22
-rw-r--r--app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild25
3 files changed, 32 insertions, 26 deletions
diff --git a/app-arch/pure-sfv/files/pure-sfv-0.3-asneeded.patch b/app-arch/pure-sfv/files/pure-sfv-0.3-asneeded.patch
deleted file mode 100644
index 926dd1318bdc..000000000000
--- a/app-arch/pure-sfv/files/pure-sfv-0.3-asneeded.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2009-01-03 18:36:24.349399478 +0100
-+++ Makefile 2009-01-03 18:36:37.218398964 +0100
-@@ -65,7 +65,7 @@
- OBJ = ${SRCS:%.c=%.o}
-
- pure-sfv: $(OBJ)
-- $(CC) -lm -DVERSION=\"$(VERSION)\" $(CFLAGS) -o $(PROG) $(OBJ)
-+ $(CC) -DVERSION=\"$(VERSION)\" $(CFLAGS) $(LDFLAGS) -o $(PROG) $(OBJ) -lm
-
- PURIFY_OPTIONS=-follow-child-processes=yes -always-use-cache-dir=yes
- PURIFY=purify
diff --git a/app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-system.patch b/app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-system.patch
new file mode 100644
index 000000000000..ca2143f1f956
--- /dev/null
+++ b/app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-system.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -54,18 +54,16 @@
+
+ VC_CRAP = pure-sfv.ncb pure-sfv.plg
+
+-CFLAGS += -Wall -Werror -O2 -g -Wno-unused
+ INSTALL_PREFIX = /usr/local
+ INSTALL_PROGRAM = /usr/bin/install -c
+
+ all: pure-sfv
+
+-CC = gcc
+
+ OBJ = ${SRCS:%.c=%.o}
+
+ pure-sfv: $(OBJ)
+- $(CC) -lm -DVERSION=\"$(VERSION)\" $(CFLAGS) -o $(PROG) $(OBJ)
++ $(CC) -DVERSION=\"$(VERSION)\" $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $(PROG) $(OBJ) -lm
+
+ PURIFY_OPTIONS=-follow-child-processes=yes -always-use-cache-dir=yes
+ PURIFY=purify
diff --git a/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild b/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
index ca26b16fbcfb..f28c6df42ec4 100644
--- a/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
+++ b/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit eutils toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="utility to test and create .sfv files and create .par files"
HOMEPAGE="http://pure-sfv.sourceforge.net/"
@@ -15,20 +15,15 @@ KEYWORDS="amd64 ~hppa ppc x86"
IUSE=""
RESTRICT="test"
-DEPEND=""
+S=${WORKDIR}
+PATCHES=( "${FILESDIR}"/${PN}-0.3-fix-build-system.patch )
-S="${WORKDIR}"
-
-src_prepare() {
- sed -i Makefile -e "s:-Werror -O2 -g::"
- epatch "${FILESDIR}"/${P}-asneeded.patch
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed"
+src_configure() {
+ append-cflags -Wall -Wno-unused
+ tc-export CC
}
src_install() {
- dobin pure-sfv || die "dobin failed"
- dodoc ReadMe.txt
+ dobin pure-sfv
+ newdoc ReadMe.txt README
}