summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-02-16 10:38:07 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-02-16 10:38:46 +0000
commite1a84d8b0cda310fef39d46059265b9ebae187c1 (patch)
tree806f9191ad9f62f7940d4c77e90d24087fd6276d /app-arch/torrentzip/torrentzip-0.2-r2.ebuild
parentdev-tex/flabels: drop usage of custom makedoc script that breaks build, bug #... (diff)
downloadgentoo-e1a84d8b0cda310fef39d46059265b9ebae187c1.tar.gz
gentoo-e1a84d8b0cda310fef39d46059265b9ebae187c1.tar.bz2
gentoo-e1a84d8b0cda310fef39d46059265b9ebae187c1.zip
app-arch/torrentzip: Get EAPI 5 bump right. Remove useless patch. Fix QA warnings.
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-arch/torrentzip/torrentzip-0.2-r2.ebuild')
-rw-r--r--app-arch/torrentzip/torrentzip-0.2-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-arch/torrentzip/torrentzip-0.2-r2.ebuild b/app-arch/torrentzip/torrentzip-0.2-r2.ebuild
new file mode 100644
index 000000000000..e3cfa1a7da32
--- /dev/null
+++ b/app-arch/torrentzip/torrentzip-0.2-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+MY_PN="trrntzip"
+MY_PV="code-9"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Advanced archiver to create identical files over multiple systems"
+HOMEPAGE="https://sourceforge.net/projects/trrntzip"
+SRC_URI="http://sourceforge.net/code-snapshots/svn/t/tr/${MY_PN}/code/${MY_P}.zip -> ${P}.zip"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+DEPEND="sys-libs/zlib"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-function-declarations.patch"
+)
+
+src_prepare() {
+ # Source-code from sf.net snapshots has CRLF...
+ EPATCH_OPTS="--binary"
+
+ epatch "${PATCHES[@]}"
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ nonfatal dodoc README AUTHORS
+}