summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-05-21 22:36:03 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-23 18:53:07 +0200
commit185c785c239b6e5f7fcadc14be183c2f5fb37cfe (patch)
tree377e47f10e95d865aa4aaa3eafc5b60d66b0f2c8 /app-arch/upx/upx-3.96-r2.ebuild
parentapp-backup/dar: remove 2.7.0 (diff)
downloadgentoo-185c785c239b6e5f7fcadc14be183c2f5fb37cfe.tar.gz
gentoo-185c785c239b6e5f7fcadc14be183c2f5fb37cfe.tar.bz2
gentoo-185c785c239b6e5f7fcadc14be183c2f5fb37cfe.zip
app-arch/upx: fix CVE-2020-24119
Bug: https://bugs.gentoo.org/790281 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20914 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-arch/upx/upx-3.96-r2.ebuild')
-rw-r--r--app-arch/upx/upx-3.96-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-arch/upx/upx-3.96-r2.ebuild b/app-arch/upx/upx-3.96-r2.ebuild
new file mode 100644
index 000000000000..cf9f4c4f87d3
--- /dev/null
+++ b/app-arch/upx/upx-3.96-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
+HOMEPAGE="https://upx.github.io/"
+SRC_URI="https://github.com/upx/upx/releases/download/v${PV}/${P}-src.tar.xz"
+
+LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/ucl-1.03
+ sys-libs/zlib"
+RDEPEND="${RDEPEND}
+ !app-arch/upx-bin"
+BDEPEND="dev-lang/perl"
+
+S="${WORKDIR}/${P}-src"
+
+PATCHES=(
+ "${FILESDIR}/${P}_CVE-2020-24119.patch"
+ "${FILESDIR}/${P}_CVE-2021-20285.patch"
+)
+
+src_compile() {
+ tc-export CXX
+ emake CXXFLAGS_WERROR="" all
+}
+
+src_install() {
+ newbin src/upx.out upx
+ dodoc BUGS NEWS PROJECTS README* THANKS doc/*.txt doc/upx.html
+ doman doc/upx.1
+}