summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-15 10:19:43 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-02-25 08:04:48 +0200
commit72b4da71f8754510153532a6bf3681f65fd6505f (patch)
tree49e32549ed588cccf9f5597779e23cdd7d17fbb7 /app-arch/upx/upx-3.96.ebuild
parentnet-im/telegram-desktop-bin: Drop old (diff)
downloadgentoo-72b4da71f8754510153532a6bf3681f65fd6505f.tar.gz
gentoo-72b4da71f8754510153532a6bf3681f65fd6505f.tar.bz2
gentoo-72b4da71f8754510153532a6bf3681f65fd6505f.zip
app-arch/upx: update to 3.96
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-arch/upx/upx-3.96.ebuild')
-rw-r--r--app-arch/upx/upx-3.96.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-arch/upx/upx-3.96.ebuild b/app-arch/upx/upx-3.96.ebuild
new file mode 100644
index 000000000000..73fe7d2befec
--- /dev/null
+++ b/app-arch/upx/upx-3.96.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
+HOMEPAGE="http://upx.github.io/"
+SRC_URI="https://github.com/upx/upx/releases/download/v${PV}/${P}-src.tar.xz"
+
+LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/ucl-1.03
+ sys-libs/zlib
+ !app-arch/upx-bin"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/${P}-src"
+
+src_compile() {
+ tc-export CXX
+ emake CXXFLAGS_WERROR="" all
+}
+
+src_install() {
+ newbin src/upx.out upx
+ dodoc BUGS NEWS PROJECTS README* THANKS doc/*.txt doc/upx.html
+ doman doc/upx.1
+}