summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2017-07-16 21:35:26 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2017-07-16 21:35:26 +0300
commit052a1affedacd447bdee25de14448dbb49757915 (patch)
treee54d67cba7b5101e6bc45f4b7b984971ccf8dc87 /app-arch
parentapp-eselect/eselect-renpy: remove old (diff)
downloadgentoo-052a1affedacd447bdee25de14448dbb49757915.tar.gz
gentoo-052a1affedacd447bdee25de14448dbb49757915.tar.bz2
gentoo-052a1affedacd447bdee25de14448dbb49757915.zip
app-arch/unrpa: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unrpa/Manifest1
-rw-r--r--app-arch/unrpa/unrpa-1.4.2.ebuild30
-rw-r--r--app-arch/unrpa/unrpa-9999.ebuild6
3 files changed, 34 insertions, 3 deletions
diff --git a/app-arch/unrpa/Manifest b/app-arch/unrpa/Manifest
index 394ba27649ed..4570dc2df240 100644
--- a/app-arch/unrpa/Manifest
+++ b/app-arch/unrpa/Manifest
@@ -1 +1,2 @@
DIST unrpa-1.4.1.tar.gz 14367 SHA256 a6f20fca0e00e09220933060c98180ad11d5a7633fc902684099b5f2c4806b0a SHA512 9b058adda9a39178950df4c39af40726cdca410f0fca699d0dec1bd5d7046c75c8811c8914c0c8756c29988b6362d3b4ad3756aa77f238eafb13d4414d3266cc WHIRLPOOL fc01837fa7a68e5121413c551abb1f9231adf04b677caec1017aaafb112da5546e5f68ea10b7cc68329bacb6499468c5b595196a4abe93ac9b7bcacb1aa5f89a
+DIST unrpa-1.4.2.tar.gz 14458 SHA256 d8c4a92380721f82f21b9c086c7755f35609aa7738ab5f8e8d3aaf1f21774090 SHA512 2608f4ec11540de1b14290ce1aaad6f06e8111a55b5c6a38c0c9e4d7228c04ccef480425f812a7cbc3913c0ed6865d0b63c8aa0d5ec9131495eab40bbdfcdcc5 WHIRLPOOL dc454ee7eb09a5a793cd0a311e17cf8c5b8cf2a276387a5957f86f5feaa4b7202f886fd83d82dc5d231d769aecbb52fdbb7839bb9cdff0939d41119a460de331
diff --git a/app-arch/unrpa/unrpa-1.4.2.ebuild b/app-arch/unrpa/unrpa-1.4.2.ebuild
new file mode 100644
index 000000000000..116e57d6b1bb
--- /dev/null
+++ b/app-arch/unrpa/unrpa-1.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Lattyware/unrpa.git"
+else
+ SRC_URI="https://github.com/Lattyware/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Ren'Py's RPA data file extractor"
+HOMEPAGE="https://github.com/Lattyware/unrpa"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ python_doscript "${PN}"
+ dodoc README
+}
diff --git a/app-arch/unrpa/unrpa-9999.ebuild b/app-arch/unrpa/unrpa-9999.ebuild
index 08b6cbe02bcc..116e57d6b1bb 100644
--- a/app-arch/unrpa/unrpa-9999.ebuild
+++ b/app-arch/unrpa/unrpa-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
inherit python-single-r1
@@ -22,9 +22,9 @@ SLOT="0"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="${PYTHON_DEPS}"
-RDEPEND=${DEPEND}
+RDEPEND="${DEPEND}"
src_install() {
- dobin ${PN}
+ python_doscript "${PN}"
dodoc README
}