summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-06-06 23:41:04 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-06-06 23:41:25 +0200
commit0bc99abe0dc0b0c178568c08f91f73ae6693c899 (patch)
tree33cca2a62ca09083ff41870bcc20302963273775 /app-arch
parentRevert "app-arch/rpm: amd64 stable wrt bug #533740" (diff)
downloadgentoo-0bc99abe0dc0b0c178568c08f91f73ae6693c899.tar.gz
gentoo-0bc99abe0dc0b0c178568c08f91f73ae6693c899.tar.bz2
gentoo-0bc99abe0dc0b0c178568c08f91f73ae6693c899.zip
app-arch/rpm: Add src_test
Closes: https://bugs.gentoo.org/657488 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/rpm/rpm-4.14.1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-arch/rpm/rpm-4.14.1.ebuild b/app-arch/rpm/rpm-4.14.1.ebuild
index 1fc3b937c5be..00c3cbeb2eb4 100644
--- a/app-arch/rpm/rpm-4.14.1.ebuild
+++ b/app-arch/rpm/rpm-4.14.1.ebuild
@@ -16,7 +16,7 @@ LICENSE="GPL-2 LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="acl caps doc lua nls python selinux"
+IUSE="acl caps doc lua nls python selinux test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
CDEPEND="!app-arch/rpm5
@@ -40,6 +40,7 @@ DEPEND="${CDEPEND}
nls? ( sys-devel/gettext )
doc? ( app-doc/doxygen )
virtual/pkgconfig
+ test? ( sys-apps/fakechroot )
"
RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-rpm )
@@ -106,6 +107,10 @@ src_install() {
perl_delete_localpod
}
+src_test() {
+ emake check
+}
+
pkg_postinst() {
if [[ -f "${EROOT}"/var/lib/rpm/Packages ]] ; then
einfo "RPM database found... Rebuilding database (may take a while)..."