summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-01-03 21:39:17 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-01-03 21:40:16 +1100
commit747fdfc3170b5bbd2ddd0093c91c3770d14cb846 (patch)
tree1bda9c75e813373a800dee47d3c59f64cb6853b9 /app-arch
parentnet-fs/cvmfs: remove 2.1.20.0_p05 (diff)
downloadgentoo-747fdfc3170b5bbd2ddd0093c91c3770d14cb846.tar.gz
gentoo-747fdfc3170b5bbd2ddd0093c91c3770d14cb846.tar.bz2
gentoo-747fdfc3170b5bbd2ddd0093c91c3770d14cb846.zip
app-arch/brotli: remove 0.6.0
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/brotli/Manifest1
-rw-r--r--app-arch/brotli/brotli-0.6.0.ebuild61
-rw-r--r--app-arch/brotli/files/brotli-0.6.0-no-rpath.patch32
3 files changed, 0 insertions, 94 deletions
diff --git a/app-arch/brotli/Manifest b/app-arch/brotli/Manifest
index d83d5e4e6587..8d9420c0611b 100644
--- a/app-arch/brotli/Manifest
+++ b/app-arch/brotli/Manifest
@@ -1,2 +1 @@
-DIST brotli-0.6.0.tar.gz 19838761 BLAKE2B 0630e9afcb04ecfd7cc6ba8dcbbe10c5ff16d9a975e13f48bd9b519bcf006afdd672aed542768590e2c5481e808e4f49c520e8a0294ce15e72cb3810a576fdde SHA512 36caa277790efeb5bff0fdc090cdcf00fd9995c4e81a60ed31d36af2e13848ec1afe5d84e6926eebbee013525191e9404e112cb7fbede16097221c5bc3dfb5d5
DIST brotli-1.0.2.tar.gz 23736359 BLAKE2B c5467dc52f97942d790b835d5e2c06d2046c3df249446b775d58e56feeb5d5fdd3e1e8e42c5eff92df2bc2b47afabd36389e14afead5fd376e18c8517d1e67f7 SHA512 b3ec98159e63b4169dea3e958d60d89247dc1c0f78aab27bfffb2ece659fa024df990d410aa15c12b2082d42e3785e32ec248dce2b116c7f34e98bb6337f9fc9
diff --git a/app-arch/brotli/brotli-0.6.0.ebuild b/app-arch/brotli/brotli-0.6.0.ebuild
deleted file mode 100644
index 91daf8320a8c..000000000000
--- a/app-arch/brotli/brotli-0.6.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-DISTUTILS_OPTIONAL="1"
-
-inherit cmake-utils distutils-r1
-
-DESCRIPTION="Generic-purpose lossless compression algorithm"
-HOMEPAGE="https://github.com/google/brotli"
-SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-
-IUSE="python test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-LICENSE="MIT python? ( Apache-2.0 )"
-
-DOCS=( README.md CONTRIBUTING.md )
-
-PATCHES=( "${FILESDIR}"/${P}-no-rpath.patch )
-
-src_prepare() {
- cmake-utils_src_prepare
- use python && distutils-r1_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -DBUILD_TESTING="$(usex test)"
- )
- cmake-utils_src_configure
- use python && distutils-r1_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- use python && distutils-r1_src_compile
-}
-
-python_test(){
- esetup.py test || die
-}
-
-src_test() {
- cmake-utils_src_test
- use python && distutils-r1_src_test
-}
-
-src_install() {
- cmake-utils_src_install
- use python && distutils-r1_src_install
-}
diff --git a/app-arch/brotli/files/brotli-0.6.0-no-rpath.patch b/app-arch/brotli/files/brotli-0.6.0-no-rpath.patch
deleted file mode 100644
index 28e70d7acfe7..000000000000
--- a/app-arch/brotli/files/brotli-0.6.0-no-rpath.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From: Tomasz Buchert <tomasz@debian.org>
-Date: Sat, 24 Jun 2017 14:40:16 +0200
-Subject: Do not set rpath on shared libs.
-
----
- CMakeLists.txt | 13 -------------
- 1 file changed, 13 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ca612d1..bf70d69 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -27,19 +27,6 @@ CMAKE_DEPENDENT_OPTION(BUILD_SHARED_LIBS "Build shared libraries" ON "NOT BROTLI
-
- include(GNUInstallDirs)
-
--# When building shared libraries it is important to set the correct rpath.
--# See https://cmake.org/Wiki/CMake_RPATH_handling#Always_full_RPATH
--if (BUILD_SHARED_LIBS)
-- add_definitions(-DBROTLI_SHARED_COMPILATION)
-- set(CMAKE_SKIP_BUILD_RPATH FALSE)
-- set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
-- set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
-- list(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES "${CMAKE_INSTALL_LIBDIR}" isSystemDir)
-- if ("${isSystemDir}" STREQUAL "-1")
-- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_LIBDIR}")
-- endif()
--endif()
--
- # Parse version information from common/version.h. Normally we would
- # define these values here and write them out to configuration file(s)
- # (i.e., config.h), but in this case we parse them from