summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-08-05 12:42:48 +0300
committerMart Raudsepp <leio@gentoo.org>2018-08-05 12:43:24 +0300
commitbafe23e26b9425982cb10251908b8a8b1d243724 (patch)
treeafd6e6ab3f9d6e9a6b46c1cb5ba903159838d944 /app-arch
parentapp-text/evince: bump to 3.28.2 (diff)
downloadgentoo-bafe23e26b9425982cb10251908b8a8b1d243724.tar.gz
gentoo-bafe23e26b9425982cb10251908b8a8b1d243724.tar.bz2
gentoo-bafe23e26b9425982cb10251908b8a8b1d243724.zip
app-arch/file-roller: bump to 3.26.2
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/file-roller/Manifest1
-rw-r--r--app-arch/file-roller/file-roller-3.26.2.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index 9a13997145fb..32b758a5f545 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1 +1,2 @@
DIST file-roller-3.24.1.tar.xz 1428216 BLAKE2B 7a74ac56fba36a60ba1f7cc0fb905b92336a349f786963a65ea2442fb078704c6e00b46686334f56cf270c861abe7ca252e0ee39f66349f6a4cc3b769a9e7dde SHA512 bd8750b8ffe3e7d3c74492e2ffdde519e7879d46f16c559d06042bac60c8ee63f492aeeaa66b4aff7c997150f4f2955e02a3b0565edf4bd7641a089ed052f268
+DIST file-roller-3.26.2.tar.xz 1436760 BLAKE2B a563f77dcc8d61e90e4e42fa4f08aded657d677b319b39f4c9fd16670a2309e81f142b7b8528e52db0be3f454efca15ccd7e9e25754a95b45800a9ca02969e12 SHA512 3572446081f931ce7cfd7eccdc9450d798164426a68bc332f9340b7c06b79ce4f1589b817c27322a0c1681d7f2cb8cf93462cde1e3df13ad40789faec1decc9f
diff --git a/app-arch/file-roller/file-roller-3.26.2.ebuild b/app-arch/file-roller/file-roller-3.26.2.ebuild
new file mode 100644
index 000000000000..b7717363afee
--- /dev/null
+++ b/app-arch/file-roller/file-roller-3.26.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+IUSE="libnotify nautilus packagekit"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/json-glib-0.14
+ >=x11-libs/gtk+-3.13.2:3
+ sys-apps/file
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.4.3:= )
+ nautilus? ( >=gnome-base/nautilus-2.22.2 )
+ packagekit? ( app-admin/packagekit-base )
+"
+# libxml2 required for glib-compile-resources
+DEPEND="${RDEPEND}
+ dev-libs/libxml2:2
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+lz4 - app-arch/lz4
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -v "${FILESDIR}"/3.22-packages.match data/packages.match || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # --disable-debug because enabling it adds -O0 to CFLAGS
+ gnome2_src_configure \
+ --disable-run-in-place \
+ --disable-static \
+ --disable-debug \
+ --enable-magic \
+ --enable-libarchive \
+ $(use_enable libnotify notification) \
+ $(use_enable nautilus nautilus-actions) \
+ $(use_enable packagekit)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}