summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-11-14 16:04:11 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 16:04:11 +0100
commitf458767ff165e37e17b0dd794bc32ef5dd8886be (patch)
treea9b97bf8245fec18a29ef3c4dcfd8f016778c3b2 /app-arch
parentapp-arch/tarsync: Port to EAPI 7 (diff)
downloadgentoo-f458767ff165e37e17b0dd794bc32ef5dd8886be.tar.gz
gentoo-f458767ff165e37e17b0dd794bc32ef5dd8886be.tar.bz2
gentoo-f458767ff165e37e17b0dd794bc32ef5dd8886be.zip
app-arch/gtk-splitter: Port to EAPI 7
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/gtk-splitter/gtk-splitter-2.2.1-r2.ebuild (renamed from app-arch/gtk-splitter/gtk-splitter-2.2.1-r1.ebuild)22
1 files changed, 9 insertions, 13 deletions
diff --git a/app-arch/gtk-splitter/gtk-splitter-2.2.1-r1.ebuild b/app-arch/gtk-splitter/gtk-splitter-2.2.1-r2.ebuild
index 0ccad4c508c7..288cc392ddae 100644
--- a/app-arch/gtk-splitter/gtk-splitter-2.2.1-r1.ebuild
+++ b/app-arch/gtk-splitter/gtk-splitter-2.2.1-r2.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-
-inherit eutils
+EAPI=7
DESCRIPTION="Split files into smaller pieces and combine them back together"
HOMEPAGE="http://gtk-splitter.sourceforge.net"
@@ -14,18 +12,16 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="crypt"
-RDEPEND="x11-libs/gtk+:2
+RDEPEND="
+ x11-libs/gtk+:2
virtual/libintl:0
crypt? ( >=app-crypt/mhash-0.8:0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-DEPEND="${RDEPEND}
- virtual/pkgconfig:*"
-
-src_prepare() {
- epatch "${FILESDIR}/"${P}-r1-desktop-QA-fixes.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-r1-desktop-QA-fixes.patch )
-src_compile() {
+src_configure() {
default
if ! use crypt ; then
@@ -35,5 +31,5 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}" install
}