summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-03-09 11:22:41 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-03-09 11:58:44 -0600
commit25a5bf5a20f8d3f4323eef363cdd270325497c0a (patch)
tree6d822fd91d27045470d45a9cc2d01234229a0588 /app-backup/attic/attic-0.16-r1.ebuild
parentapp-admin/salt: updating for msgpack rename (from msgpack-python) (diff)
downloadgentoo-25a5bf5a20f8d3f4323eef363cdd270325497c0a.tar.gz
gentoo-25a5bf5a20f8d3f4323eef363cdd270325497c0a.tar.bz2
gentoo-25a5bf5a20f8d3f4323eef363cdd270325497c0a.zip
app-backup/attic: allow use of renamed msgpack
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-backup/attic/attic-0.16-r1.ebuild')
-rw-r--r--app-backup/attic/attic-0.16-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-backup/attic/attic-0.16-r1.ebuild b/app-backup/attic/attic-0.16-r1.ebuild
new file mode 100644
index 000000000000..3959eafcf9d1
--- /dev/null
+++ b/app-backup/attic/attic-0.16-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jborg/attic.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jborg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Attic is a deduplicating backup program written in Python."
+HOMEPAGE="https://attic-backup.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="libressl"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ dev-python/llfuse[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ ${RDEPEND}"
+
+python_prepare_all() {
+ # allow use of new (renamed) msgpack
+ sed -i '/msgpack/d' setup.py || die
+ distutils-r1_python_prepare_all
+}