summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2017-07-31 14:12:50 -0400
committerDavid Seifert <soap@gentoo.org>2017-07-31 20:28:24 +0200
commit0ec9b53b49d7c26b20a6f32e86212a87f43bc968 (patch)
tree6f981622a1d12b712a6ca44abef2aa7671ec8785 /app-backup/btrbk
parentapp-backup/btrbk: 0.25.1 version bump (diff)
downloadgentoo-0ec9b53b49d7c26b20a6f32e86212a87f43bc968.tar.gz
gentoo-0ec9b53b49d7c26b20a6f32e86212a87f43bc968.tar.bz2
gentoo-0ec9b53b49d7c26b20a6f32e86212a87f43bc968.zip
app-backup/btrbk: 0.24.0 requires <sys-fs/btrfs-progs-4.8.3
See https://github.com/digint/btrbk/commit/6cf5d59 Closes: https://github.com/gentoo/gentoo/pull/5251
Diffstat (limited to 'app-backup/btrbk')
-rw-r--r--app-backup/btrbk/btrbk-0.24.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-backup/btrbk/btrbk-0.24.0-r1.ebuild b/app-backup/btrbk/btrbk-0.24.0-r1.ebuild
new file mode 100644
index 000000000000..8f10060231fa
--- /dev/null
+++ b/app-backup/btrbk/btrbk-0.24.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://dev.tty0.ch/btrbk.git"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
+ KEYWORDS="amd64 arm x86"
+fi
+
+DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
+HOMEPAGE="https://digint.ch/btrbk/"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+pv"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ net-misc/openssh
+ pv? ( sys-apps/pv )
+ >=sys-fs/btrfs-progs-3.18.2 <sys-fs/btrfs-progs-4.8.3"
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" install
+}