summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/rdumpfs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/rdumpfs')
-rw-r--r--app-backup/rdumpfs/Manifest1
-rw-r--r--app-backup/rdumpfs/metadata.xml11
-rw-r--r--app-backup/rdumpfs/rdumpfs-20131002.ebuild29
3 files changed, 41 insertions, 0 deletions
diff --git a/app-backup/rdumpfs/Manifest b/app-backup/rdumpfs/Manifest
new file mode 100644
index 000000000000..d2ad39e5ad89
--- /dev/null
+++ b/app-backup/rdumpfs/Manifest
@@ -0,0 +1 @@
+DIST rdumpfs-20131002.tar.gz 2373 SHA256 bb02e119e2248ae95eecfbade77370093a544a24b5078132856c70da6d6c3a1d SHA512 29aa4a3ac9a3d22cff24a84fb1db86aa53d78514bb16f25e70f801a83fce9eb9a523929170eaa9562aa76bce682eb52e400c7468220e0ec876978032bf174969 WHIRLPOOL 24a2556514804d11f84c97617882da2740926dc4c1d1970657635df258bf189f0fb81ce48bd953743fcf2e24b0b3213b914c65d0864506efbf723b00569693c2
diff --git a/app-backup/rdumpfs/metadata.xml b/app-backup/rdumpfs/metadata.xml
new file mode 100644
index 000000000000..0931b530109e
--- /dev/null
+++ b/app-backup/rdumpfs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">chneukirchen/rdumpfs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-backup/rdumpfs/rdumpfs-20131002.ebuild b/app-backup/rdumpfs/rdumpfs-20131002.ebuild
new file mode 100644
index 000000000000..a95599654827
--- /dev/null
+++ b/app-backup/rdumpfs/rdumpfs-20131002.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vcs-snapshot
+
+COMMIT="b7e8e7b0efd9d73344e022e204f2e99e6321136e"
+DESCRIPTION="a rsync-based dump file system backup tool"
+HOMEPAGE="https://github.com/chneukirchen/rdumpfs"
+SRC_URI="${HOMEPAGE}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+xattr"
+
+DEPEND=""
+RDEPEND="net-misc/rsync[xattr?]"
+
+src_prepare() {
+ use xattr || sed -i '/^rsync_args=/s/X//' "${PN}" || die
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc README
+}