summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Fischl <github@fischl-online.de>2022-10-23 11:45:14 +0200
committerSam James <sam@gentoo.org>2022-10-31 18:44:47 +0000
commit137d8384c2e65265a0fab9c7bed03f7750bdc2b2 (patch)
tree1491e1d95aa132c9f46eee6fdd395a179ec7b587 /app-backup
parentapp-backup/burp: remove 2.5.4 (diff)
downloadgentoo-137d8384c2e65265a0fab9c7bed03f7750bdc2b2.tar.gz
gentoo-137d8384c2e65265a0fab9c7bed03f7750bdc2b2.tar.bz2
gentoo-137d8384c2e65265a0fab9c7bed03f7750bdc2b2.zip
app-backup/burp: bump 3.1.2 (masked)
Bug: https://bugs.gentoo.org/864851 Signed-off-by: Anton Fischl <github@fischl-online.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/burp/Manifest1
-rw-r--r--app-backup/burp/burp-3.1.2.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/app-backup/burp/Manifest b/app-backup/burp/Manifest
index 83ef3e04a4e9..f9f24666294c 100644
--- a/app-backup/burp/Manifest
+++ b/app-backup/burp/Manifest
@@ -1 +1,2 @@
DIST burp-2.4.0.tar.gz 624032 BLAKE2B 4a1ff48236dc631dd6d545480a33af3cdf8020c3088f1ca09ab66ac5cec8128d262b9b991bf9e3229c80f75a4746d338073a0a43fdb67a2fe21a0fd4f243469d SHA512 ea81a12e54c6d88b702dd09dc4fa5a724d1e322bdfba2643c9312a9077c9edc63f6ca0f6cb3a6ebecb6ad9feb1cc26c114277b2308d9903f4abb0442a9be7c19
+DIST burp-3.1.2.tar.gz 549260 BLAKE2B a8767d9ac2188e7a44fa2e8e4ba08dd3a5edeac268afcf196db5cae06e8bcc1faae1a48ba1873ef43fdbb9764946384233a755779e09984217b4334781529024 SHA512 a832502f617b66b87feeff032002bc25827809a165e3fb6ef85a9f3d847e308e9fa69f138b7e80662366fa3de09b39f7ef209b529d82c3d487dca11fe3ebcddf
diff --git a/app-backup/burp/burp-3.1.2.ebuild b/app-backup/burp/burp-3.1.2.ebuild
new file mode 100644
index 000000000000..2d84d0488b11
--- /dev/null
+++ b/app-backup/burp/burp-3.1.2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="Network backup and restore client and server for Unix and Windows"
+HOMEPAGE="https://burp.grke.org/"
+SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl ipv6 test xattr"
+
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="acct-group/burp
+ acct-user/burp
+ dev-libs/uthash
+ dev-libs/openssl:0=
+ net-libs/librsync:=
+ sys-libs/ncurses:0=
+ sys-libs/libcap
+ sys-libs/zlib
+ virtual/libcrypt:=
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )"
+DEPEND="${COMMON_DEPEND}
+ elibc_musl? ( sys-libs/queue-standalone )
+ test? ( dev-libs/check )"
+BDEPEND=">=sys-devel/autoconf-2.71
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ virtual/logger"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
+ "${FILESDIR}"/${PN}-2.0.54-server_user.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ --sysconfdir=/etc/burp
+ --enable-largefile
+ --runstatedir=/run
+ $(use_enable acl)
+ $(use_enable ipv6)
+ $(use_enable xattr)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # See https://github.com/grke/burp/issues/869
+ local -x CK_DEFAULT_TIMEOUT=10
+ default
+}
+
+src_install() {
+ default
+ keepdir /var/spool/burp
+ fowners -R root:${PN} /var/spool/burp
+ fperms 0770 /var/spool/burp
+
+ emake DESTDIR="${D}" install-configs
+ fowners -R root:${PN} /etc/burp
+ fperms 0750 /etc/burp
+ fperms 0640 /etc/burp/burp-server.conf
+ fperms 0750 /etc/burp/clientconfdir
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+ elog "Burp ebuilds now support the autoupgrade mechanism in both"
+ elog "client and server mode. In both cases it is disabled by"
+ elog "default. You almost certainly do NOT want to enable it in"
+ elog "client mode because upgrades obtained this way will not be"
+ elog "managed by Portage."
+
+ if [[ ! -e ${EROOT}/etc/burp/CA/index.txt ]]; then
+ elog ""
+ elog "At first run burp server will generate DH parameters and SSL"
+ elog "certificates. You should adjust configuration before."
+ elog "Server configuration is located at"
+ elog ""
+ elog " ${EROOT}/etc/burp/burp-server.conf"
+ elog ""
+ fi
+
+ # According to PMS this can be a space-separated list of version
+ # numbers, even though in practice it is typically just one.
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 ${oldver}) -lt 2 ]]; then
+ ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
+ ewarn "the server config file by default. If you use bedup, please"
+ ewarn "update your scripts to invoke it as"
+ ewarn ""
+ ewarn " bedup -c ${EROOT}/etc/burp/burp-server.conf"
+ ewarn ""
+ ewarn "Otherwise deduplication will not work!"
+ break
+ fi
+ done
+}