summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 04:13:12 +0100
committerSam James <sam@gentoo.org>2021-07-31 23:13:40 +0100
commit54e4cb4b94f7ede4f3bbe5e159bae3b556c9275f (patch)
treed8d7fc78f1923086923020988de1549cbf6f8101 /app-backup
parentnet-analyzer/munin: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-54e4cb4b94f7ede4f3bbe5e159bae3b556c9275f.tar.gz
gentoo-54e4cb4b94f7ede4f3bbe5e159bae3b556c9275f.tar.bz2
gentoo-54e4cb4b94f7ede4f3bbe5e159bae3b556c9275f.zip
app-backup/bareos: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Revbump because the new tmpfiles inherit adds a new dependency (virtual/tmpfiles). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/bareos/bareos-19.2.9-r1.ebuild (renamed from app-backup/bareos/bareos-19.2.9.ebuild)7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-backup/bareos/bareos-19.2.9.ebuild b/app-backup/bareos/bareos-19.2.9-r1.ebuild
index e2d48fb23962..1c9bdced2c67 100644
--- a/app-backup/bareos/bareos-19.2.9.ebuild
+++ b/app-backup/bareos/bareos-19.2.9-r1.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{7,8,9} )
CMAKE_WARN_UNUSED_CLI=no
#CMAKE_REMOVE_MODULES=yes
-inherit python-any-r1 systemd cmake
+inherit python-any-r1 systemd cmake tmpfiles
DESCRIPTION="Featureful client/server network backup suite"
HOMEPAGE="https://www.bareos.org/"
@@ -330,14 +330,15 @@ src_install() {
diropts -m0755
keepdir /var/log/bareos
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}"/tmpfiles.d-bareos.conf bareos.conf
+ newtmpfiles "${FILESDIR}"/tmpfiles.d-bareos.conf bareos.conf
# make sure bareos group can execute bareos libexec scripts
fowners -R root:bareos /usr/libexec/bareos
}
pkg_postinst() {
+ tmpfiles_process bareos.conf
+
if use clientonly; then
fowners root:bareos /var/lib/bareos
else