summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2018-02-15 16:52:38 +0100
committerMarek Szuba <marecki@gentoo.org>2018-02-15 17:31:22 +0100
commit5cf5671423f3528b0bcdba6d4ba501d1353b7947 (patch)
treeff3e899641b0e9d4785813bf1db1e8a6673e4045 /app-backup
parentdev-php/PEAR-Text_CAPTCHA_Numeral: Revbump for tests, EAPI and eclass changes (diff)
downloadgentoo-5cf5671423f3528b0bcdba6d4ba501d1353b7947.tar.gz
gentoo-5cf5671423f3528b0bcdba6d4ba501d1353b7947.tar.bz2
gentoo-5cf5671423f3528b0bcdba6d4ba501d1353b7947.zip
app-backup/burp: bump to 2.1.28
This is the first version declared stable by upstream since 2.0.54. Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/burp/Manifest1
-rw-r--r--app-backup/burp/burp-2.1.28.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/app-backup/burp/Manifest b/app-backup/burp/Manifest
index a6d88e459f8d..fad230022e40 100644
--- a/app-backup/burp/Manifest
+++ b/app-backup/burp/Manifest
@@ -2,3 +2,4 @@ DIST burp-2.0.54.tar.gz 558845 BLAKE2B f6a868b09ad73e3b8aa171993849c8fec43c141d1
DIST burp-2.1.22.tar.gz 582938 BLAKE2B dbc0b7612e9cda2186d16426ec1a39559af965fcbc393259e5d4d1f376c666e8532f25dbe51d2ec816fc2e630f81b059c77aee572c562bf47f466f4114e875fd SHA512 028b48c585cdc607eb00af5f60e01541a54885b8084e0353d01b1e01744848967011cd330a443ae143884852c2dbc18fb25f364ce129a31ccbcf0f8d25ccb730
DIST burp-2.1.24.tar.gz 586055 BLAKE2B 6186e791e8b0cea74ecfbd4a85624f2492bd2721e705d8f5fb6783eb03390c7c10d88e4e4e33095aff985c70e6da59b3bb3b0f652cc850f443dabef23517c05f SHA512 b23f5e33510493e08b9b6eda405a017c8f75811fa18c9bcb6f96fbf716a79934e6c714f1258c39a81dcc52ef1a88e3629a0862bbd2462fbdc30cc7fb1b117ba6
DIST burp-2.1.26.tar.gz 588548 BLAKE2B f17d03cd79972d1a6bee3163092cd8957208024ca121113493c942cf268e53ab4dadfe05b74c5653a42088f1fb5e4e16b11632c602f2f1f09ecf1010ef43050c SHA512 abfd6866413b4bd9e382fde4cd1f2a51b41a306605dc1fce309011c4340c6e58900839878ade4e53e2d70077ea8ea92eac3ee727783e6a316efaa7b0e75e116f
+DIST burp-2.1.28.tar.gz 590482 BLAKE2B 933e7b966ea75012b46af828fc50df1dbdafec3d6fef41149dc37d9526dd8819a3f5ffef53b75a5a196781a37e8220b58ba81dbeff8e7f0006617c7d021949b5 SHA512 8784f9dfad58cdcd1f25f669bccefaaf8df95c02ae317d17b6a70e4215e40eb16e8f65bdee3e25e463cc9b58516d2244f72877d4fbd1509938ed9d542d7a62ad
diff --git a/app-backup/burp/burp-2.1.28.ebuild b/app-backup/burp/burp-2.1.28.ebuild
new file mode 100644
index 000000000000..0b3678fbd2a0
--- /dev/null
+++ b/app-backup/burp/burp-2.1.28.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools systemd user versionator
+
+DESCRIPTION="Network backup and restore client and server for Unix and Windows"
+HOMEPAGE="http://burp.grke.org/"
+SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl ipv6 libressl test xattr"
+
+CDEPEND="dev-libs/uthash
+ net-libs/librsync
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ test? ( dev-libs/check )"
+RDEPEND="${CDEPEND}
+ virtual/logger"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
+ "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
+ "${FILESDIR}"/${PN}-2.0.54-server_user.patch
+)
+
+pkg_setup() {
+ enewgroup "${PN}"
+ enewuser "${PN}" -1 "" "" "${PN}"
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ --sysconfdir=/etc/burp
+ --enable-largefile
+ $(use_enable acl)
+ $(use_enable ipv6)
+ $(use_enable xattr)
+ )
+ # --runstatedir option will only work from autoconf-2.70 onwards
+ runstatedir='/run' \
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ fowners -R root:${PN} /var/spool/burp
+ fperms 0770 /var/spool/burp
+
+ emake DESTDIR="${D}" install-configs
+ fowners -R root:${PN} /etc/burp
+ fperms 0750 /etc/burp
+ fperms 0640 /etc/burp/burp-server.conf
+ fperms 0750 /etc/burp/clientconfdir
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+ elog "Burp ebuilds now support the autoupgrade mechanism in both"
+ elog "client and server mode. In both cases it is disabled by"
+ elog "default. You almost certainly do NOT want to enable it in"
+ elog "client mode because upgrades obtained this way will not be"
+ elog "managed by Portage."
+
+ if [[ ! -e /etc/burp/CA/index.txt ]]; then
+ elog ""
+ elog "At first run burp server will generate DH parameters and SSL"
+ elog "certificates. You should adjust configuration before."
+ elog "Server configuration is located at"
+ elog ""
+ elog " /etc/burp/burp-server.conf"
+ elog ""
+ fi
+
+ # According to PMS this can be a space-separated list of version
+ # numbers, even though in practice it is typically just one.
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if [[ $(get_major_version ${oldver}) -lt 2 ]]; then
+ ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
+ ewarn "the server config file by default. If you use bedup, please"
+ ewarn "update your scripts to invoke it as"
+ ewarn ""
+ ewarn " bedup -c /etc/burp/burp-server.conf"
+ ewarn ""
+ ewarn "Otherwise deduplication will not work!"
+ break
+ fi
+ done
+}