summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-04-19 19:27:33 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-04-19 19:27:33 -0400
commita25012b232a18f90f6a9adae4918537425a95758 (patch)
tree23c0b4413503226820bac66922752b4deae14fdc /app-backup
parentsci-mathematics/dunshire: new revision supporting python-3.{7,8}. (diff)
downloadgentoo-a25012b232a18f90f6a9adae4918537425a95758.tar.gz
gentoo-a25012b232a18f90f6a9adae4918537425a95758.tar.bz2
gentoo-a25012b232a18f90f6a9adae4918537425a95758.zip
app-backup/untangle-https-backup: new EAPI=7 revision for python-3.{7,8}.
Closes: https://bugs.gentoo.org/718198 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/untangle-https-backup/untangle-https-backup-0.0.10-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-backup/untangle-https-backup/untangle-https-backup-0.0.10-r1.ebuild b/app-backup/untangle-https-backup/untangle-https-backup-0.0.10-r1.ebuild
new file mode 100644
index 000000000000..16ff114854ef
--- /dev/null
+++ b/app-backup/untangle-https-backup/untangle-https-backup-0.0.10-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+PYTHON_REQ_USE="ssl(+)"
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+DESCRIPTION="Back up Untangle configurations via the web admin UI"
+HOMEPAGE="http://michael.orlitzky.com/code/untangle-https-backup.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_install() {
+ distutils-r1_src_install
+ doman "doc/man8/${PN}.8"
+ dodoc "doc/${PN}.example.ini"
+}