summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-09 13:01:07 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-09 13:01:41 +0100
commitc4dddf8969db4f5824caca702131db4b7bdc8035 (patch)
tree2e911488cbe6354dc3743ae1e4c1c0561ecbafb2 /app-backup
parenteclass/kernel-2: fix USE=symlink (diff)
downloadgentoo-c4dddf8969db4f5824caca702131db4b7bdc8035.tar.gz
gentoo-c4dddf8969db4f5824caca702131db4b7bdc8035.tar.bz2
gentoo-c4dddf8969db4f5824caca702131db4b7bdc8035.zip
app-backup/borgmatic: add 1.5.14
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.5.14.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 62d8db17a1ba..5c59cf4ea624 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1 +1,2 @@
DIST borgmatic-1.5.13.tar.gz 72469 BLAKE2B 3a71be201143a96968bb1ea6008b62e11f6ab199f44f38d0d66f31f24827a8f32cc7b8f50cc5d33a8bbd7046e6697afe509525be90dd9519f4c686b8737f64c5 SHA512 60bcbcc825db3f93a423ab8e44e0b0809ff4937d8e41bc56ec6226e4865c3a66fae8b6749d33cdb0692ea9dd07cfff56750ff2feee68c96791b83c9dd5f35433
+DIST borgmatic-1.5.14.tar.gz 273464 BLAKE2B 8325643c79f1e2e0a6d94f1e73dbf45bef82ba3d63c48b6652ffc2fb6a7d1dd5b45fb369346292129f948ae88216e93c2b0ab88ff889ae49cfb0dd321bed4125 SHA512 eb0aedfafe06f90dc3e54a19299a9ea7e8c83bdec0a305228bf13b951d75a5d2a68d2fe6b037adb57588b036081075fb697e000c8ea4ff467a582a6b1ac9fd60
diff --git a/app-backup/borgmatic/borgmatic-1.5.14.ebuild b/app-backup/borgmatic/borgmatic-1.5.14.ebuild
new file mode 100644
index 000000000000..06c3a588685e
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.5.14.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+# Fails due to problems with dev-python/flexmock-0.10.4; see Bug #740128
+RESTRICT="test"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/pykwalify-1.6.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
+ ')"
+#BDEPEND="
+# test? (
+# $(python_gen_cond_dep '
+# dev-python/flexmock[${PYTHON_USEDEP}]
+# ')
+# )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-systemd_service_bin_path.patch
+ "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Unlike the other two test files in integration/commands, which use the
+ # relevant modules' respective APIs, test_borgmatic.py tries to call the
+ # 'borgmatic' executable - which by the time we execute src_test will
+ # not have been created yet. Adding --install to distutils_enable_tests would
+ # likely take care of this - but between the aforementioned behaviour
+ # inconsistency and the fact the only test run from this file as of version
+ # 1.5.13 is the parsing of contents of 'borgmatic --version', just skip it.
+ rm -f "${S}"/tests/integration/commands/test_borgmatic.py
+}
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " generate-borgmatic-config"
+ fi
+ elog
+ elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
+}