summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-01 03:48:56 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:54:04 +0100
commit284310bd3b7345df86ab3a7b1e1875c0935070b6 (patch)
tree8586205d3be227dd419fa84ee809b39aad876cc7 /app-benchmarks/libc-bench
parentapp-benchmarks/i7z: drop unused flag-o-matic, add pkgconfig BDEPEND (diff)
downloadgentoo-284310bd3b7345df86ab3a7b1e1875c0935070b6.tar.gz
gentoo-284310bd3b7345df86ab3a7b1e1875c0935070b6.tar.bz2
gentoo-284310bd3b7345df86ab3a7b1e1875c0935070b6.zip
app-benchmarks/libc-bench: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-benchmarks/libc-bench')
-rw-r--r--app-benchmarks/libc-bench/libc-bench-20110206.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/app-benchmarks/libc-bench/libc-bench-20110206.ebuild b/app-benchmarks/libc-bench/libc-bench-20110206.ebuild
index 72efbc992efa..75f49f8d8689 100644
--- a/app-benchmarks/libc-bench/libc-bench-20110206.ebuild
+++ b/app-benchmarks/libc-bench/libc-bench-20110206.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit eutils toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Time and memory-efficiency tests of various C/POSIX standard library functions"
HOMEPAGE="http://www.etalabs.net/libc-bench.html http://git.musl-libc.org/cgit/libc-bench/"
@@ -12,15 +12,15 @@ SRC_URI="http://www.etalabs.net/releases/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-src_prepare() {
- epatch "${FILESDIR}"/respect-flags.patch
-}
+PATCHES=(
+ "${FILESDIR}"/respect-flags.patch
+)
src_configure() {
tc-export CC
- CFLAGS+=" ${CPPFLAGS}"
+
+ append-cflags "${CPPFLAGS}"
}
src_install() {