summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/spew
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/spew')
-rw-r--r--app-benchmarks/spew/Manifest1
-rw-r--r--app-benchmarks/spew/files/fix-automake-1.13.patch28
-rw-r--r--app-benchmarks/spew/files/fix-format-security.patch24
-rw-r--r--app-benchmarks/spew/files/fix-ncurses-tinfo.patch29
-rw-r--r--app-benchmarks/spew/files/remove-symlinks-makefile.patch26
-rw-r--r--app-benchmarks/spew/metadata.xml13
-rw-r--r--app-benchmarks/spew/spew-1.0.8-r1.ebuild44
-rw-r--r--app-benchmarks/spew/spew-1.0.8.ebuild42
8 files changed, 207 insertions, 0 deletions
diff --git a/app-benchmarks/spew/Manifest b/app-benchmarks/spew/Manifest
new file mode 100644
index 000000000000..f259675ba8aa
--- /dev/null
+++ b/app-benchmarks/spew/Manifest
@@ -0,0 +1 @@
+DIST spew-1.0.8.tgz 162091 SHA256 200da1b4390a5e4bf91cb7278b3ad813194f0e395abc0da6296ac415e11a76cb SHA512 ec76a1e681bbaabef6cdc63ced5114a856a312e91c5ff3e0d1536221583a1c939f9308139863670695121c8c720123a6d0697491867ccafc091607888cc81b56 WHIRLPOOL 9aac2fec8b514271fcaf3e72eb6affa505fcaae274e1966e67371c7671aa8e46cf9c0ab7345b83de4ce60a6a51b72cb9e17c692839a4eb810762bc8b851bc20a
diff --git a/app-benchmarks/spew/files/fix-automake-1.13.patch b/app-benchmarks/spew/files/fix-automake-1.13.patch
new file mode 100644
index 000000000000..c046c1b955eb
--- /dev/null
+++ b/app-benchmarks/spew/files/fix-automake-1.13.patch
@@ -0,0 +1,28 @@
+diff -Naur spew-1.0.8.orig/configure.ac spew-1.0.8/configure.ac
+--- spew-1.0.8.orig/configure.ac 2010-05-14 01:17:52.000000000 -0400
++++ spew-1.0.8/configure.ac 2013-06-21 09:06:42.000000000 -0400
+@@ -2,20 +2,13 @@
+ # Process this file with autoconf to produce a configure script.
+
+ AC_PREREQ(2.57)
+-AC_INIT(src/spew.cpp)
++AC_INIT(spew, 1.0.8)
++AC_CONFIG_SRCDIR(src/spew.cpp)
+ AC_CONFIG_AUX_DIR(config)
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+ AM_MAINTAINER_MODE
+
+-SPEW_AGE=1
+-SPEW_REVISION=0
+-SPEW_CURRENT=8
+-AC_SUBST(SPEW_AGE)
+-AC_SUBST(SPEW_REVISION)
+-AC_SUBST(SPEW_CURRENT)
+-VERSION=$SPEW_AGE.$SPEW_REVISION.$SPEW_CURRENT
+-
+-AM_INIT_AUTOMAKE(spew, $VERSION)
++AM_INIT_AUTOMAKE
+
+ # Checks for programs.
+ AC_PROG_CXX
diff --git a/app-benchmarks/spew/files/fix-format-security.patch b/app-benchmarks/spew/files/fix-format-security.patch
new file mode 100644
index 000000000000..dd34d875bd0e
--- /dev/null
+++ b/app-benchmarks/spew/files/fix-format-security.patch
@@ -0,0 +1,24 @@
+diff -Naur spew-1.0.8.orig/src/spew.cpp spew-1.0.8/src/spew.cpp
+--- spew-1.0.8.orig/src/spew.cpp 2010-05-14 01:06:18.000000000 -0400
++++ spew-1.0.8/src/spew.cpp 2014-11-19 08:39:31.806338597 -0500
+@@ -285,7 +285,7 @@
+ PATTERN_LOOKUP[Job::PATTERN_USER_DEFINED],
+ PATTERN_LOOKUP[Job::PATTERN_USER_DEFINED],
+ PATTERN_LOOKUP[DEFAULT_PATTERN]);
+- fprintf(stdout, outStr);
++ fprintf(stdout, "%s", outStr);
+
+ fprintf(stdout, "\nReport bugs to Andrew Patterson <andrew.patterson@hp.com>.\n");
+ }
+diff -Naur spew-1.0.8.orig/src/SpewTuiStatisticsWindow.cpp spew-1.0.8/src/SpewTuiStatisticsWindow.cpp
+--- spew-1.0.8.orig/src/SpewTuiStatisticsWindow.cpp 2008-05-13 00:47:17.000000000 -0400
++++ spew-1.0.8/src/SpewTuiStatisticsWindow.cpp 2014-11-19 08:39:52.527339540 -0500
+@@ -278,7 +278,7 @@
+ "");
+ if (mSpewTui->getCurrentIteration() > 0)
+ {
+- int len = snprintf(NULL, 0, (char *)mTotalRunTime.getElapsedTimeStr().c_str());
++ int len = snprintf(NULL, 0, "%s", (char *)mTotalRunTime.getElapsedTimeStr().c_str());
+ mvwprintw(mWindow,
+ RUNTIME_FIELD_STARTY,
+ RUNTIME_FIELD_STARTX + RUNTIME_FIELD_WIDTH - len,
diff --git a/app-benchmarks/spew/files/fix-ncurses-tinfo.patch b/app-benchmarks/spew/files/fix-ncurses-tinfo.patch
new file mode 100644
index 000000000000..9905e2057042
--- /dev/null
+++ b/app-benchmarks/spew/files/fix-ncurses-tinfo.patch
@@ -0,0 +1,29 @@
+diff -Naur spew-1.0.8.orig/configure.ac spew-1.0.8/configure.ac
+--- spew-1.0.8.orig/configure.ac 2014-11-19 08:15:31.284273029 -0500
++++ spew-1.0.8/configure.ac 2014-11-19 08:16:07.063274657 -0500
+@@ -21,6 +21,7 @@
+ # Checks for libraries.
+ AC_CHECK_LIB(popt, poptGetContext, ,AC_MSG_ERROR([PACKAGE] requires popt))
+ AC_CHECK_LIB(ncurses, wresize, ,AC_MSG_ERROR([PACKAGE] requires ncurses))
++PKG_CHECK_MODULES(NCURSES, [ncurses])
+
+ # Checks for header files.
+ AC_HEADER_STDC
+diff -Naur spew-1.0.8.orig/src/Makefile.am spew-1.0.8/src/Makefile.am
+--- spew-1.0.8.orig/src/Makefile.am 2014-11-19 08:15:31.311273030 -0500
++++ spew-1.0.8/src/Makefile.am 2014-11-19 08:16:57.034276932 -0500
+@@ -24,7 +24,7 @@
+ libtui_a_SOURCES = \
+ Tui.cpp Tui.h
+
+-LDADD = libcommon.a libtui.a
++LDADD = libcommon.a libtui.a $(NCURSES_LIBS)
+
+ bin_PROGRAMS = spew
+ spew_SOURCES = spew.cpp \
+@@ -37,4 +37,5 @@
+ SpewTuiStatisticsWindow.cpp SpewTuiStatisticsWindow.h \
+ SpewTuiStatusWindow.cpp SpewTuiStatusWindow.h
+
++spew_CFLAGS = $(NCURSES_CFLAGS)
+ spew_LDFLAGS = $(STATIC_LINK)
diff --git a/app-benchmarks/spew/files/remove-symlinks-makefile.patch b/app-benchmarks/spew/files/remove-symlinks-makefile.patch
new file mode 100644
index 000000000000..e5c369a7f8a0
--- /dev/null
+++ b/app-benchmarks/spew/files/remove-symlinks-makefile.patch
@@ -0,0 +1,26 @@
+diff -Naur spew-1.0.8.orig/man/Makefile.am spew-1.0.8/man/Makefile.am
+--- spew-1.0.8.orig/man/Makefile.am 2008-05-13 00:47:28.000000000 -0400
++++ spew-1.0.8/man/Makefile.am 2011-04-05 09:39:32.000000000 -0400
+@@ -10,11 +10,5 @@
+ sed -e 's!SPEW_VERSION!$(VERSION)!' \
+ -e 's!SYSCONFDIR!$(sysconfdir)!' $< >$@
+
+-install-data-am: install-man install-man-local
+-
+-install-man-local:
+- (cd $(DESTDIR)$(mandir)/man1 && $(LN_S) -f spew.1 gorge.1)
+- (cd $(DESTDIR)$(mandir)/man1 && $(LN_S) -f spew.1 regorge.1)
+-
+ help2man:
+ help2man --section=1 --no-info --name="measures I/O performance and/or generates I/O load" --include="spew.1.include" --output=spew.1.in ../src/spew
+diff -Naur spew-1.0.8.orig/src/Makefile.am spew-1.0.8/src/Makefile.am
+--- spew-1.0.8.orig/src/Makefile.am 2008-05-13 00:47:20.000000000 -0400
++++ spew-1.0.8/src/Makefile.am 2011-04-05 09:35:16.000000000 -0400
+@@ -38,7 +38,3 @@
+ SpewTuiStatusWindow.cpp SpewTuiStatusWindow.h
+
+ spew_LDFLAGS = $(STATIC_LINK)
+-
+-install-exec-local:
+- (cd $(DESTDIR)$(bindir) && $(LN_S) -f spew gorge)
+- (cd $(DESTDIR)$(bindir) && $(LN_S) -f spew regorge)
diff --git a/app-benchmarks/spew/metadata.xml b/app-benchmarks/spew/metadata.xml
new file mode 100644
index 000000000000..5234f3362711
--- /dev/null
+++ b/app-benchmarks/spew/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <longdescription lang="en">
+ An I/O performance measurement and load generation tool. Writes
+ and/or reads generated data to or from a character device, block
+ device, or regular file.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-benchmarks/spew/spew-1.0.8-r1.ebuild b/app-benchmarks/spew/spew-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..c03d87205019
--- /dev/null
+++ b/app-benchmarks/spew/spew-1.0.8-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Measures I/O performance and/or generates I/O load"
+HOMEPAGE="http://spew.berlios.de/"
+SRC_URI="ftp://ftp.berlios.de/pub/spew/1.0.8/spew-1.0.8.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~mips ~ppc ~ppc64 x86"
+IUSE="static"
+
+DEPEND="static? ( sys-libs/ncurses[-gpm] dev-libs/popt[static-libs] )
+ !static? ( sys-libs/ncurses dev-libs/popt )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-format-security.patch
+ epatch "${FILESDIR}"/fix-automake-1.13.patch
+ epatch "${FILESDIR}"/remove-symlinks-makefile.patch
+ epatch "${FILESDIR}"/fix-ncurses-tinfo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static static-link)
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dosym ${PN} /usr/bin/gorge
+ dosym ${PN} /usr/bin/regorge
+ dosym ${PN}.1.bz2 /usr/share/man/man1/gorge.1.bz2
+ dosym ${PN}.1.bz2 /usr/share/man/man1/reorge.1.bz2
+}
diff --git a/app-benchmarks/spew/spew-1.0.8.ebuild b/app-benchmarks/spew/spew-1.0.8.ebuild
new file mode 100644
index 000000000000..7886a6fe7752
--- /dev/null
+++ b/app-benchmarks/spew/spew-1.0.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Measures I/O performance and/or generates I/O load"
+HOMEPAGE="http://spew.berlios.de/"
+SRC_URI="ftp://ftp.berlios.de/pub/spew/1.0.8/spew-1.0.8.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~mips ~ppc ~ppc64 x86"
+IUSE="static"
+
+DEPEND="static? ( sys-libs/ncurses[-gpm] dev-libs/popt[static-libs] )
+ !static? ( sys-libs/ncurses dev-libs/popt )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-automake-1.13.patch
+ epatch "${FILESDIR}"/remove-symlinks-makefile.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static static-link)
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dosym ${PN} /usr/bin/gorge
+ dosym ${PN} /usr/bin/regorge
+ dosym ${PN}.1.bz2 /usr/share/man/man1/gorge.1.bz2
+ dosym ${PN}.1.bz2 /usr/share/man/man1/reorge.1.bz2
+}