summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/bin2iso
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/bin2iso')
-rw-r--r--app-cdr/bin2iso/Manifest1
-rw-r--r--app-cdr/bin2iso/bin2iso-19b-r2.ebuild34
-rw-r--r--app-cdr/bin2iso/files/bin2iso-19b-sanity-checks.patch30
-rw-r--r--app-cdr/bin2iso/metadata.xml9
4 files changed, 74 insertions, 0 deletions
diff --git a/app-cdr/bin2iso/Manifest b/app-cdr/bin2iso/Manifest
new file mode 100644
index 000000000000..e017fa680abe
--- /dev/null
+++ b/app-cdr/bin2iso/Manifest
@@ -0,0 +1 @@
+DIST bin2iso-19b.tar.bz2 9805 SHA256 450abbd1216f499d156172c4cdbd05722abd1d2150ef73d999e1caf19b433abf SHA512 1f2dbde824ee32eb3be878bf1b96167d753a3f40eb0baf59f3c72907dcc6ce4c999c04d008efde5269dec306b6eab3dd2b15a18a81388c105545abd04e1769c5 WHIRLPOOL b343f74acf40295eb759ac83bb3aea6b03999a04fe7a14deed6fd81b3cf4a4d33b0f65e10ae48be528ab953d3d158df6e98dfbfa6a906a0f5f11498f97b4a5fc
diff --git a/app-cdr/bin2iso/bin2iso-19b-r2.ebuild b/app-cdr/bin2iso/bin2iso-19b-r2.ebuild
new file mode 100644
index 000000000000..b1a7f22ac426
--- /dev/null
+++ b/app-cdr/bin2iso/bin2iso-19b-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="converts RAW format (.bin/.cue) files to ISO/WAV format"
+HOMEPAGE="http://users.andara.com/~doiron/bin2iso/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ edos2unix *.c
+ epatch "${FILESDIR}"/${P}-sanity-checks.patch
+}
+
+src_compile() {
+ $(tc-getCC) bin2iso19b_linux.c -o ${PN} ${CFLAGS} ${LDFLAGS} || die "compile failed"
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed"
+ dodoc readme.txt
+}
diff --git a/app-cdr/bin2iso/files/bin2iso-19b-sanity-checks.patch b/app-cdr/bin2iso/files/bin2iso-19b-sanity-checks.patch
new file mode 100644
index 000000000000..5803bc103a86
--- /dev/null
+++ b/app-cdr/bin2iso/files/bin2iso-19b-sanity-checks.patch
@@ -0,0 +1,30 @@
+Add more checks to prevent segfaults in ill-formatted files
+
+http://bugs.gentoo.org/show_bug.cgi?id=90540
+
+--- bin2iso19b_linux.c
++++ bin2iso19b_linux.c
+@@ -237,6 +237,10 @@
+ // Get the 'mode'
+ if (strncmp(&Line[2], "TRACK ", 6)==0)
+ {
++ if (Line[8] < '0' || Line[8] > '9' || Line[9] < '0' || Line[9] > '9') {
++ printf("Error: Track # is not a 2 digit number\n");
++ exit(1);
++ }
+ strncpy(track->num, &Line[8], 2); track->num[2] = '\0';
+
+ track->mode = UNKNOWN;
+@@ -246,7 +250,11 @@
+ if(strncmp(&Line[11], "MODE2/2352", 10)==0) track->mode = MODE2_2352;
+ if(strncmp(&Line[11], "MODE2/2336", 10)==0) track->mode = MODE2_2336;
+ }
+- else return(1);
++ else
++ {
++ printf("Error: 2nd line does not begin with ' TRACK '\n");
++ exit(1);
++ }
+
+ // Set the name
+ strcpy(track->name, sBinFilename);
diff --git a/app-cdr/bin2iso/metadata.xml b/app-cdr/bin2iso/metadata.xml
new file mode 100644
index 000000000000..0937d8ba0535
--- /dev/null
+++ b/app-cdr/bin2iso/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-optical</herd>
+<longdescription>
+Converts RAW format (.bin) files to ISO/WAV format and recovers .cue
+files from .bin ones
+</longdescription>
+</pkgmetadata>