summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-05-18 10:36:28 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-05-18 10:36:28 +0300
commitced8efd370c6c6b6c8b3303e960254733d22e997 (patch)
tree3391951b859746f0bfcc458373bfffe557dd32bc /app-containers
parentapp-containers/crun: backport bugfix (diff)
downloadgentoo-ced8efd370c6c6b6c8b3303e960254733d22e997.tar.gz
gentoo-ced8efd370c6c6b6c8b3303e960254733d22e997.tar.bz2
gentoo-ced8efd370c6c6b6c8b3303e960254733d22e997.zip
app-containers/crun: drop 1.4.4, 1.4.5
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/crun/Manifest2
-rw-r--r--app-containers/crun/crun-1.4.4.ebuild66
-rw-r--r--app-containers/crun/crun-1.4.5.ebuild77
3 files changed, 0 insertions, 145 deletions
diff --git a/app-containers/crun/Manifest b/app-containers/crun/Manifest
index eb08a9c6bef5..0ded84c3c024 100644
--- a/app-containers/crun/Manifest
+++ b/app-containers/crun/Manifest
@@ -1,4 +1,2 @@
-DIST crun-1.4.4.tar.xz 877892 BLAKE2B 57e48c0a229db3f54212177cef3fdb3f59b4bb1d1cc865da956f026a35837d839489bd126f880d7a9ceb18f5cffbf0e32ac9ae59a4cd39c34e3aff5b32c0559a SHA512 1756dccf6509457a5dc114d43c4f4e99258a20c3437dfe06016d080989c5d3035f5735d62d18ab537b660ec36de04df369a2582745baf4ab680af367a19830fd
-DIST crun-1.4.5.tar.xz 879044 BLAKE2B c80cae28c23140086682493a7dddb40640491e3ea827f0a7376d9be12570111d056022f50b8d7c574ca07790753d20de2314db5b89463994c4fffbc7576c372d SHA512 9f288279615fdf587018c465047fc8793daae280ab864bf9046994983239129d50f2eb89cac9b092e5cdc49a10f3523ab403a3f0e7451f7536b79f651a355153
DIST crun-1.8.1.tar.xz 692152 BLAKE2B b5dce1a454641221c591f50ac8519d4e9e9d892ea56232fa3fc9916934c19eba5853019238b1837cd5fb61f0dec5e0e6a11c02f628bece3b69c9c4f5750addae SHA512 6230b378f4746aff1d53f3ed797229b2056ece76e8e5b22d6f5f7b42e6042c6aff5294298f3cfd1293b4a87371dfa58cc69e57455e20948abd7269059ad39042
DIST crun-1.8.4.tar.xz 729552 BLAKE2B 8169518a0ddd8deb3820f7030d03dec6941d5d34fb73a036b82f15b0d8f2f702e117de00b829a16cb9976e118f5a5ca732b1cd572708f664cfeafc564f883824 SHA512 2ed80db2e7ddd1438bbe33e99ec2cdbcc55c4869504f719ff9302e834929752af09a59cd905accb37ee5f6cae3b9b16fd4f4c3fdab31db5fc38b007c1505bfa0
diff --git a/app-containers/crun/crun-1.4.4.ebuild b/app-containers/crun/crun-1.4.4.ebuild
deleted file mode 100644
index 602bc237b4ef..000000000000
--- a/app-containers/crun/crun-1.4.4.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit python-any-r1
-
-DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
-HOMEPAGE="https://github.com/containers/crun"
-SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv"
-IUSE="+bpf +caps criu +seccomp selinux systemd static-libs"
-
-DEPEND="
- dev-libs/yajl:=
- sys-kernel/linux-headers
- caps? ( sys-libs/libcap )
- criu? ( >=sys-process/criu-3.15 )
- seccomp? ( sys-libs/libseccomp )
- systemd? ( sys-apps/systemd:= )
-"
-RDEPEND="${DEPEND}
- selinux? ( sec-policy/selinux-container )"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
-"
-
-# the crun test suite is comprehensive to the extent that tests will fail
-# within a sandbox environment, due to the nature of the privileges
-# required to create linux "containers".
-RESTRICT="test"
-
-src_configure() {
- local myeconfargs=(
- $(use_enable bpf)
- $(use_enable caps)
- $(use_enable criu)
- $(use_enable seccomp)
- $(use_enable systemd)
- $(usex static-libs '--enable-shared --enable-static' '--enable-shared --disable-static' '' '')
- )
-
- # Need https://github.com/containers/libocispec/pull/107 to be merged & land in
- # a crun release that syncs up w/ latest version, then can drop CONFIG_SHELL
- CONFIG_SHELL="${BROOT}/bin/bash" econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- emake -C libocispec
- emake crun
-}
-
-src_install() {
- emake "DESTDIR=${D}" install-exec
- doman crun.1
- einstalldocs
-
- einfo "Cleaning up .la files"
- find "${ED}" -name '*.la' -delete || die
-}
diff --git a/app-containers/crun/crun-1.4.5.ebuild b/app-containers/crun/crun-1.4.5.ebuild
deleted file mode 100644
index c35d66de254a..000000000000
--- a/app-containers/crun/crun-1.4.5.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-# Can drop autotools/eautoreconf after next release & glibc patch gone
-inherit autotools python-any-r1
-
-DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
-HOMEPAGE="https://github.com/containers/crun"
-SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv"
-IUSE="+bpf +caps criu +seccomp selinux systemd static-libs"
-
-DEPEND="
- dev-libs/yajl:=
- sys-kernel/linux-headers
- caps? ( sys-libs/libcap )
- criu? ( >=sys-process/criu-3.15 )
- seccomp? ( sys-libs/libseccomp )
- systemd? ( sys-apps/systemd:= )
-"
-RDEPEND="${DEPEND}
- selinux? ( sec-policy/selinux-container )"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
-"
-
-# the crun test suite is comprehensive to the extent that tests will fail
-# within a sandbox environment, due to the nature of the privileges
-# required to create linux "containers".
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.4.5-glibc-2.36.patch
-)
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable bpf)
- $(use_enable caps)
- $(use_enable criu)
- $(use_enable seccomp)
- $(use_enable systemd)
- $(usex static-libs '--enable-shared --enable-static' '--enable-shared --disable-static' '' '')
- )
-
- # Need https://github.com/containers/libocispec/pull/107 to be merged & land in
- # a crun release that syncs up w/ latest version, then can drop CONFIG_SHELL
- CONFIG_SHELL="${BROOT}/bin/bash" econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- emake -C libocispec
- emake crun
-}
-
-src_install() {
- emake "DESTDIR=${D}" install-exec
- doman crun.1
- einstalldocs
-
- einfo "Cleaning up .la files"
- find "${ED}" -name '*.la' -delete || die
-}