summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-05 17:56:18 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-05 17:57:28 +0100
commit61e52be135927ec4028d2a9988339096ff9470e5 (patch)
treeedf616de3146c236dba9efcea5c2ee84f75873e7 /app-crypt/acme-sh/acme-sh-9999.ebuild
parentapp-crypt/acme-sh: add myself as co-maint (diff)
downloadgentoo-61e52be135927ec4028d2a9988339096ff9470e5.tar.gz
gentoo-61e52be135927ec4028d2a9988339096ff9470e5.tar.bz2
gentoo-61e52be135927ec4028d2a9988339096ff9470e5.zip
app-crypt/acme-sh: update DESCRIPTION, HOMEPAGE, SRC_URI
Updated description to match upstream. Updated homepage and SRC_URI to match new name on Github Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-crypt/acme-sh/acme-sh-9999.ebuild')
-rw-r--r--app-crypt/acme-sh/acme-sh-9999.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/app-crypt/acme-sh/acme-sh-9999.ebuild b/app-crypt/acme-sh/acme-sh-9999.ebuild
index 7ff01d8cd7e6..3bd355e89826 100644
--- a/app-crypt/acme-sh/acme-sh-9999.ebuild
+++ b/app-crypt/acme-sh/acme-sh-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,20 +7,21 @@ EGIT_REPO_URI="https://github.com/Neilpang/${PN/-/.}.git"
inherit git-r3
-DESCRIPTION="An ACME Shell script"
-HOMEPAGE="https://github.com/Neilpang/acme.sh"
+DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
+HOMEPAGE="https://github.com/acmesh-official/acme.sh"
SRC_URI=""
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE=""
-RDEPEND="net-misc/curl
+RDEPEND="
+ net-misc/curl
|| ( dev-libs/libressl dev-libs/openssl:0 )
|| ( net-analyzer/netcat net-analyzer/openbsd-netcat )
|| ( net-misc/socat www-servers/apache:2 www-servers/nginx )
- virtual/cron"
+ virtual/cron
+"
src_install() {
einstalldocs
@@ -29,15 +30,19 @@ src_install() {
keepdir /etc/acme-sh
doenvd "${FILESDIR}"/99acme-sh
+
insinto /etc/bash/bashrc.d
doins "${FILESDIR}"/acme.sh
exeinto /usr/share/acme.sh
doexe acme.sh
+
insinto /usr/share/acme.sh/dnsapi
doins -r dnsapi/*.sh
+
insinto /usr/share/acme.sh/deploy
doins -r deploy/*.sh
+
insinto /usr/share/acme.sh/notify
doins -r notify/*.sh