summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2018-10-14 13:48:52 +0300
committerMichał Górny <mgorny@gentoo.org>2018-10-20 17:07:27 +0200
commit8c80c15d06b64de071f84d9c8e6f608d603f0fb5 (patch)
tree8abb7fe60bc29d4693df76a6378ac5d35c2632f6 /app-crypt/acme-sh/acme-sh-9999.ebuild
parentmedia-radio/js8call: new package, from rich0 overlay (diff)
downloadgentoo-8c80c15d06b64de071f84d9c8e6f608d603f0fb5.tar.gz
gentoo-8c80c15d06b64de071f84d9c8e6f608d603f0fb5.tar.bz2
gentoo-8c80c15d06b64de071f84d9c8e6f608d603f0fb5.zip
app-crypt/acme-sh: new ebuild
A pure Unix shell script implementing ACME client protocol Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Package-Manager: Portage-2.3.49, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10139 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-crypt/acme-sh/acme-sh-9999.ebuild')
-rw-r--r--app-crypt/acme-sh/acme-sh-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/acme-sh/acme-sh-9999.ebuild b/app-crypt/acme-sh/acme-sh-9999.ebuild
new file mode 100644
index 000000000000..23935922162c
--- /dev/null
+++ b/app-crypt/acme-sh/acme-sh-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/Neilpang/${PN/-/.}.git"
+
+inherit git-r3
+
+DESCRIPTION="An ACME Shell script"
+HOMEPAGE="https://github.com/Neilpang/acme.sh"
+SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="net-misc/curl
+ || ( dev-libs/libressl dev-libs/openssl:0 )
+ || ( net-analyzer/netcat6 net-analyzer/openbsd-netcat )
+ || ( net-misc/socat www-servers/apache:2 www-servers/nginx:0 )
+ virtual/cron"
+
+src_install() {
+ einstalldocs
+ newdoc dnsapi/README.md README-dnsapi.md
+ newdoc deploy/README.md README-deploy.md
+
+ keepdir /etc/acme-sh
+ doenvd "${FILESDIR}"/99acme-sh
+ insinto /etc/bash/bashrc.d
+ doins "${FILESDIR}"/acme.sh
+
+ exeinto /usr/share/acme.sh
+ doexe acme.sh
+ insinto /usr/share/acme.sh/dnsapi
+ doins -r dnsapi/*.sh
+ insinto /usr/share/acme.sh/deploy
+ doins -r deploy/*.sh
+
+ dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
+}