summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-09-10 22:53:16 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-09-10 22:55:03 -0500
commit466269894398435bc478164ba425e335b1952ad0 (patch)
treee691aa52b52e04b1071cc51e265e5f4c5ed951e3 /app-crypt/acme
parentapp-crypt/certbot-nginx: drop 1.28.0 (diff)
downloadgentoo-466269894398435bc478164ba425e335b1952ad0.tar.gz
gentoo-466269894398435bc478164ba425e335b1952ad0.tar.bz2
gentoo-466269894398435bc478164ba425e335b1952ad0.zip
app-crypt/acme: add 1.30.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/acme')
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-1.30.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index 5974cb4f2eca..8ae96f64bfb0 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1 +1,2 @@
DIST certbot-1.29.0.tar.gz 1367853 BLAKE2B c0d8d2c05a061b2d50564a97bf17ae883bd443321bf99cea13fbae196c7ec876231d803d5389e524997dd8632035d5ad60b1a99b025a22a65d0865d564cfafc5 SHA512 755781e12e0e4cdb41aa16d90ab6a334ef41a98630e08127a867c8e8813ee45ebd3f6f54168fe747900f6ab59539e414ffed7891c05746b3a7af2e2a96a8d522
+DIST certbot-1.30.0.tar.gz 1370072 BLAKE2B c9286bc6dfee59c5a7b458430b08ee273615b42e40d2355b41c5d58a0b8757d83551e947058660e4abda88d7f11c16184a248c313b4d01e145df0e39b717bf86 SHA512 15727a7a38a9cbe4890a347c0cc2a795be19502ece28034400d41cf96a6d4bef197890bd85cd02ecc6a792e3502ae8aa663aad45e980047567f0d3b161cbe3df
diff --git a/app-crypt/acme/acme-1.30.0.ebuild b/app-crypt/acme/acme-1.30.0.ebuild
new file mode 100644
index 000000000000..a905a81b75cc
--- /dev/null
+++ b/app-crypt/acme/acme-1.30.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.5.0[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest