summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-03-02 11:19:17 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-03-02 11:22:35 -0600
commit9c555606a54a52c14558a9e810e70d6b4fff77e0 (patch)
tree4bcb46414b3c8ab45ec7b63c5c7f3a1892e7f203 /app-crypt/acme
parentdev-python/octave_kernel: don't install twice for testing (diff)
downloadgentoo-9c555606a54a52c14558a9e810e70d6b4fff77e0.tar.gz
gentoo-9c555606a54a52c14558a9e810e70d6b4fff77e0.tar.bz2
gentoo-9c555606a54a52c14558a9e810e70d6b4fff77e0.zip
app-crypt/acme: 1.24.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/acme')
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-1.24.0.ebuild39
-rw-r--r--app-crypt/acme/acme-9999.ebuild4
3 files changed, 42 insertions, 2 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index e6e554036048..481e3eb30361 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,2 +1,3 @@
DIST certbot-1.22.0.tar.gz 1352714 BLAKE2B 213dc08d3a88e0d20d6324c026a47eb96b9e45fbde41f79e37c2e62c655d7c6df01292e110d2e78ea085dfc62ef3c7b623279224029c9ae2a59e69c5c00054a5 SHA512 9a7a0d11e9fd5bd59b526a2cc5d0029b972e34a2bf41035c2d8ab535b93fc6d985ee8ea3dd5e50a7f4af80450135b739d1297245ad21b47b8362cddb03738932
DIST certbot-1.23.0.tar.gz 1361107 BLAKE2B a1b1e029436eb32840d56ca815478df3774a30b69552c5f7a4ca18b054a49c8ce342fe7f7ffecfb6c0fb93338bb722d57e4537e1f142ab162bb8208575ee34be SHA512 bb64139c6406e7c87571beb94d435e079368cbb249d96b522dab72a9529b3a825f9258aac70c5a582d58117c700da281fb43ed8369f40a236c0b7e6acb5237b0
+DIST certbot-1.24.0.tar.gz 1360049 BLAKE2B e1c7f4b56ac66b73f74eb8c9d6c31bc12529c2e7a1a51679e715227e61a2e72a30aa5053abe1684be9d665e399ca67f2d11afcc5c60c76bb86d1c0feb68308ca SHA512 fa2a45e650107f48da1e5d7d7469e8a23598e0e0e1127bc62a66ba2351a8fe518da6ec3e53370f7042631ee74e82c65fcc323c71e8f485911363e805ccb6f045
diff --git a/app-crypt/acme/acme-1.24.0.ebuild b/app-crypt/acme/acme-1.24.0.ebuild
new file mode 100644
index 000000000000..1d353f46ad14
--- /dev/null
+++ b/app-crypt/acme/acme-1.24.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.3.0[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
diff --git a/app-crypt/acme/acme-9999.ebuild b/app-crypt/acme/acme-9999.ebuild
index 25d2c8f15342..1d353f46ad14 100644
--- a/app-crypt/acme/acme-9999.ebuild
+++ b/app-crypt/acme/acme-9999.ebuild
@@ -30,8 +30,8 @@ RDEPEND="
>=dev-python/josepy-1.10.0[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-17.3.0[${PYTHON_USEDEP}]
dev-python/pyrfc3339[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
>=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
"