summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Levermann <simon@slevermann.de>2017-02-02 16:08:19 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-02-02 16:08:42 +0100
commit3b52a51234c375a7c39b3299f94026226559db27 (patch)
tree25a557686322ba4ed2c07948604f66dc9858962a /app-crypt/argon2
parentsys-devel/lld: Re-enable tests in the live ebuild (diff)
downloadgentoo-3b52a51234c375a7c39b3299f94026226559db27.tar.gz
gentoo-3b52a51234c375a7c39b3299f94026226559db27.tar.bz2
gentoo-3b52a51234c375a7c39b3299f94026226559db27.zip
app-crypt/argon2: version bump
Closes: https://github.com/gentoo/gentoo/pull/3644 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-crypt/argon2')
-rw-r--r--app-crypt/argon2/Manifest1
-rw-r--r--app-crypt/argon2/argon2-20161029.ebuild29
-rw-r--r--app-crypt/argon2/files/argon2-20161029-makefile-soname-symlinks.patch28
3 files changed, 58 insertions, 0 deletions
diff --git a/app-crypt/argon2/Manifest b/app-crypt/argon2/Manifest
index 2a1ad7d2ffb1..1bda176e7b51 100644
--- a/app-crypt/argon2/Manifest
+++ b/app-crypt/argon2/Manifest
@@ -1 +1,2 @@
DIST argon2-20160821.tar.gz 1170019 SHA256 f81456ae31337a13a1a1b8ffe994d71ace741833a97a75f0c1a76259639bf3b8 SHA512 e5b7484a2f3212d78481e7994457d69e5f42d6132b31f86d8de106e8e3fa8ffa3b7244fd74b63d15846be3a0fd407e6c57c6f766cdfa0ee1e3d7706124853b5f WHIRLPOOL ad476d23572ebe8701a71a79aff09dd08a0db3dde9b0a6104884a91309d651298adfb514cc7de9c585672ffbc816c9afae67cbbe09b3f9a300624036981c3d78
+DIST argon2-20161029.tar.gz 1506864 SHA256 fe0049728b946b58b94cc6db89b34e2d050c62325d16316a534d2bedd78cd5e7 SHA512 e1f947a97e8b5f292dd32a6f1ea0ef3f2e411629218653821886ec4e1d5f8289d5b8f4b8bf0a37e69c344a83b975c695947d6b49fd2001a0e4273bebd4792892 WHIRLPOOL d90a0bbd17abf146e47ef5f1c9a759234396d9779213210484047120091b9e420f11926d502c1bb03a464625f64d3ec1df34f10ec5ba23572d18184fddaf113b
diff --git a/app-crypt/argon2/argon2-20161029.ebuild b/app-crypt/argon2/argon2-20161029.ebuild
new file mode 100644
index 000000000000..2658c7b06419
--- /dev/null
+++ b/app-crypt/argon2/argon2-20161029.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Password hashing software that won the Password Hashing Competition (PHC)"
+HOMEPAGE="https://github.com/P-H-C/phc-winner-argon2"
+SRC_URI="https://github.com/P-H-C/phc-winner-argon2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 CC0-1.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="-static-libs"
+
+S="${WORKDIR}/phc-winner-${P}"
+PATCHES=(
+ "${FILESDIR}/${P}-makefile-soname-symlinks.patch"
+ )
+src_prepare() {
+ default
+ if ! use static-libs; then
+ sed -i -e 's/LIBRARIES = \$(LIB_SH) \$(LIB_ST)/LIBRARIES = \$(LIB_SH)/' Makefile || die "sed failed!"
+ fi
+ sed -i -e 's/-O3 //' Makefile || die "sed failed"
+ sed -i -e 's/-g //' Makefile || die "sed failed"
+ sed -i -e "s/-march=\$(OPTTARGET) /${CFLAGS} /" Makefile || die "sed failed"
+ sed -i -e 's/CFLAGS += -march=\$(OPTTARGET)//' Makefile || die "sed failed"
+}
diff --git a/app-crypt/argon2/files/argon2-20161029-makefile-soname-symlinks.patch b/app-crypt/argon2/files/argon2-20161029-makefile-soname-symlinks.patch
new file mode 100644
index 000000000000..11892de11158
--- /dev/null
+++ b/app-crypt/argon2/files/argon2-20161029-makefile-soname-symlinks.patch
@@ -0,0 +1,28 @@
+diff --git a/Makefile b/Makefile
+index 1838c13..85aa710 100644
+--- a/Makefile
++++ b/Makefile
+@@ -87,8 +87,10 @@ endif
+ endif
+
+ LIB_SH := lib$(LIB_NAME).$(LIB_EXT)
++LIB_SH_VERSION := $(LIB_SH).0
+ LIB_ST := lib$(LIB_NAME).a
+ LIBRARIES = $(LIB_SH) $(LIB_ST)
++INSTALL_LIBRARIES = $(LIBRARIES) $(LIB_SH_VERSION)
+ HEADERS = include/argon2.h
+
+ INSTALL = install
+@@ -153,9 +155,11 @@ format:
+ -i include/*.h src/*.c src/*.h src/blake2/*.c src/blake2/*.h
+
+ install: $(RUN) libs
++ mv $(LIB_SH) $(LIB_SH_VERSION)
++ ln -sf $(LIB_SH_VERSION) $(LIB_SH)
+ $(INSTALL) -d $(INST_INCLUDE)
+ $(INSTALL) $(HEADERS) $(INST_INCLUDE)
+ $(INSTALL) -d $(INST_LIBRARY)
+- $(INSTALL) $(LIBRARIES) $(INST_LIBRARY)
++ $(INSTALL) $(INSTALL_LIBRARIES) $(INST_LIBRARY)
+ $(INSTALL) -d $(INST_BINARY)
+ $(INSTALL) $(RUN) $(INST_BINARY)