summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-08-01 21:00:45 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-08-01 21:01:47 +0300
commitfb33d5f53f6863e910df7f0b7f0455d0b10678f0 (patch)
treee798d999a779281d60279b7c5a9e05de1afbe700 /app-crypt/ccid
parentsys-devel/autoconf: Enable running the test suite! (diff)
downloadgentoo-fb33d5f53f6863e910df7f0b7f0455d0b10678f0.tar.gz
gentoo-fb33d5f53f6863e910df7f0b7f0455d0b10678f0.tar.bz2
gentoo-fb33d5f53f6863e910df7f0b7f0455d0b10678f0.zip
app-crypt/ccid: add 1.4.35
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-crypt/ccid')
-rw-r--r--app-crypt/ccid/Manifest1
-rw-r--r--app-crypt/ccid/ccid-1.4.35.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-crypt/ccid/Manifest b/app-crypt/ccid/Manifest
index 4f268011dce2..965c8b562557 100644
--- a/app-crypt/ccid/Manifest
+++ b/app-crypt/ccid/Manifest
@@ -1,2 +1,3 @@
DIST ccid-1.4.33.tar.bz2 659673 BLAKE2B f8dd37ed4fd2bd15e6313417dc01feecd0303502d24eeae101ad13233510b5e26b08439c4de453abc734695618faa1c8031e545d045527aa841ab9056a3d729e SHA512 ccfcecbaca4c8f1ee4a4925bd313ced6d6f15ad422cbcc387627aef203a9ae0ff7775c4a2c5d25978ab33ebfd93c34de50e1f783df787b77ea7c774a45ed126b
DIST ccid-1.4.34.tar.bz2 667477 BLAKE2B 81f8f97fdb4526fa2f0bfe0890cc447c87671989159022a51fa15ed6e85760f7fc3a9b3f673e2cbf72373a9fc67df5304c0a93a945b97f5ad483de213f5b1a45 SHA512 8a71c100e2f0adfd6de89a86dab6690629b10c91d1fddc0a810df2ebeaea978eaaa7c6a21fa964b5cd1ea277b0efe75a2885b490f9bd9ac4776b8ff1848e4122
+DIST ccid-1.4.35.tar.bz2 676789 BLAKE2B d1123c024a798a22906a5c2c2e35f5485b8d2252ddec28571af835bbf169bc5abeb26fea871ef70d67270cc1eb52f992c56f0abb74f6deed555f15e39dbf4756 SHA512 da990b5537ec35baa1b36b9c4be7f1bdccfc149cfa4ce024ddf59504f2a2044273057c1454f227fdad8f6b04fceaf48b88e70d4d0a5475384749b367529deaeb
diff --git a/app-crypt/ccid/ccid-1.4.35.ebuild b/app-crypt/ccid/ccid-1.4.35.ebuild
new file mode 100644
index 000000000000..54ad487a2623
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.4.35.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs udev
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="https://ccid.apdu.fr https://github.com/LudovicRousseau/CCID"
+SRC_URI="https://ccid.apdu.fr/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="twinserial kobil-midentity +usb"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.8.3
+ usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}"
+BDEPEND="kernel_linux? ( virtual/pkgconfig )"
+
+DOCS=( README.md AUTHORS )
+
+src_configure() {
+ econf \
+ LEX=: \
+ $(use_enable twinserial) \
+ $(use_enable usb libusb)
+}
+
+src_compile() {
+ default
+ use kobil-midentity && emake -C contrib/Kobil_mIDentity_switch
+}
+
+src_install() {
+ default
+
+ if use kobil-midentity; then
+ dosbin contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch
+ doman contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch.8
+ fi
+
+ if use kernel_linux; then
+ # note: for eudev support, rules probably will always need to be
+ # installed to /usr
+
+ # ccid >=1.4.11 version changed the rules drastically in a minor
+ # release to no longer use the pcscd group. Using the old ones in
+ # the mean time.
+ udev_newrules "${FILESDIR}"/92_pcscd_ccid-2.rules 92-pcsc-ccid.rules
+
+ # disable Kobil_mIDentity_switch udev rule with USE=-kobil-midentity
+ if ! use kobil-midentity; then
+ sed \
+ -e '/Kobil_mIDentity_switch/s/^/#/' \
+ -i "${D}/$(get_udevdir)"/rules.d/92-pcsc-ccid.rules || die
+ fi
+
+ fi
+}