summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-06-07 14:40:44 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-06-07 14:53:32 -0500
commit0063e20d4f4d0abc12730ad8abc7679e994559f2 (patch)
tree1986f9355f8417fbf1913605301ddeee11cd26a4 /app-crypt/certbot-apache
parentapp-crypt/certbot: 0.25.0 bup (diff)
downloadgentoo-0063e20d4f4d0abc12730ad8abc7679e994559f2.tar.gz
gentoo-0063e20d4f4d0abc12730ad8abc7679e994559f2.tar.bz2
gentoo-0063e20d4f4d0abc12730ad8abc7679e994559f2.zip
app-crypt/certbot-apache: 0.25.0 bup
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-crypt/certbot-apache')
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-0.25.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index af62754b0704..cf0c716a4f32 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1,2 +1,3 @@
DIST certbot-0.23.0.tar.gz 1144448 BLAKE2B 820c4e3a0245a4ccda90884e38093d4f95ebf8c06ccb93c80a277a69074a6ab3bac3451f4e8f9af6c1c36edd9d871e10de9240d847e6eeac5fb8e0fbcdb3cdcb SHA512 397562fa7f5ef5daea8ccf70dc21898f8b792dc6a07aa24035fa378da8af3dd5d0734c3fbf6080c28d17f050db46ec0ea637be81d4ce648fa5ab2add2cfd41ed
DIST certbot-0.24.0.tar.gz 1149694 BLAKE2B 7c57d59ced97de77e0f98eb11a2bba418ee81ba0eb4506ebc010cb0060c92820617ba2a3464dd398bfec6dc86f4c2dc8e22461d76ae51ccfbb97afab3bbb3681 SHA512 b067da7eea54deb72ff4b516382cbe480ffebcb378489a2b0c52955f7399401d936d8d6587d88473d6f4fa9e864de94514941bde9727a5babbf2d6211ea61b20
+DIST certbot-0.25.0.tar.gz 1163858 BLAKE2B 9439b253a505f3cfb25f4ca33e6745b53ac51514dc34b31dd234c8db7dd07b9cb47b0a7edcc565dd7dee4678d0edd99590d2f235fedb77193e8ad1f0459c6b7a SHA512 af0f2498d79e9d54f0609b21b8ec40efe9fbcfa5162eb18bbb8b10cc230b31db6af81c4e85af243d92c527efc55634402b30960d014085f6e6af6e679ca75592
diff --git a/app-crypt/certbot-apache/certbot-apache-0.25.0.ebuild b/app-crypt/certbot-apache/certbot-apache-0.25.0.ebuild
new file mode 100644
index 000000000000..243b9c52b64b
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-0.25.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=app-crypt/certbot-0.21.1[${PYTHON_USEDEP}]
+ >app-crypt/acme-0.24.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}