summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-15 22:35:33 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-15 22:36:45 +0200
commitee6db034e008888995dc63d5fc809d8ea40a5ecb (patch)
treecc434f495beede6e557a04ee6e1f02dd9b419b52 /app-crypt/certbot-apache
parentkde-frameworks/plasma: Add upstream fixes (diff)
downloadgentoo-ee6db034e008888995dc63d5fc809d8ea40a5ecb.tar.gz
gentoo-ee6db034e008888995dc63d5fc809d8ea40a5ecb.tar.bz2
gentoo-ee6db034e008888995dc63d5fc809d8ea40a5ecb.zip
app-crypt/certbot-apache: Version bump to 0.13.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-crypt/certbot-apache')
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-0.13.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index 69f2c1392180..c0b12c5cd938 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1 +1,2 @@
DIST certbot-0.11.1.tar.gz 817693 SHA256 89c45639746a79a22e32d86dbf9352cda1a4ea218aa1433d3aa61d90c715f52c SHA512 77ab66be8e9e16c3588f9a822db553c3ba8caf5bda91a810c0bccfd2bed144ccab06dae33551df474dba05a679045dc02966bc6f8facecdcba3f00c7b9773f0a WHIRLPOOL 5514e471ef9f7fd75321da7828927c34bec757bcd0c7477814da953286f6a0a414b5cf5969243df41100f172bb2f0b451019f7e1130123a2fac9fcd88a0abd99
+DIST certbot-0.13.0.tar.gz 827956 SHA256 ef23822043435261750e7a9c1211601b65f9f9a5e634cfbf5011632b0a62edd4 SHA512 c0bc38b48f0c9731236bba9f4c05da960bfc038be629c5f4c63e80812595c6e0fb679ff901a8bf160efa119b532b5a629435ed595e3b1049f7a15f2c2dd8eb40 WHIRLPOOL 9c0217042c9864b5b0a621aa9a478f1943eced10f68cb913d2b2874fd96774969266e424be08ea345167bb9994f9b0ae2c0557a5c63eb1d37f2b09171bd87b49
diff --git a/app-crypt/certbot-apache/certbot-apache-0.13.0.ebuild b/app-crypt/certbot-apache/certbot-apache-0.13.0.ebuild
new file mode 100644
index 000000000000..848fa90e898b
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-0.13.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="~app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ <=dev-python/python-augeas-0.5.0[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}