summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-01-22 17:16:46 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-01-22 17:18:09 +0100
commitc7f4025028c3275088d7b36279c9e28ab5800b60 (patch)
treed4dcd91acc2cc0ce975b345125ad96ea6fcb176e /app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
parentnet-irc/rbot: remove unused patch (diff)
downloadgentoo-c7f4025028c3275088d7b36279c9e28ab5800b60.tar.gz
gentoo-c7f4025028c3275088d7b36279c9e28ab5800b60.tar.bz2
gentoo-c7f4025028c3275088d7b36279c9e28ab5800b60.zip
app-crypt/certbot-nginx: Initial version
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-crypt/certbot-nginx/certbot-nginx-9999.ebuild')
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
new file mode 100644
index 000000000000..babe1c82fd63
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-ngin}-${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ ~app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"