summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-02-04 01:27:49 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2017-02-04 03:30:48 +0200
commitf0663b688886caad77bca4bfeda596f5b282f6ba (patch)
treecaff768b6358a36ad99f3f0a7075537f87d8a7d5 /app-crypt/dieharder
parentapp-crypt/cardpeek: eapi bump (diff)
downloadgentoo-f0663b688886caad77bca4bfeda596f5b282f6ba.tar.gz
gentoo-f0663b688886caad77bca4bfeda596f5b282f6ba.tar.bz2
gentoo-f0663b688886caad77bca4bfeda596f5b282f6ba.zip
app-crypt/dieharder: eapi bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-crypt/dieharder')
-rw-r--r--app-crypt/dieharder/dieharder-3.31.1-r1.ebuild31
1 files changed, 22 insertions, 9 deletions
diff --git a/app-crypt/dieharder/dieharder-3.31.1-r1.ebuild b/app-crypt/dieharder/dieharder-3.31.1-r1.ebuild
index d389c1b5e2ba..1a44ed1e5c8c 100644
--- a/app-crypt/dieharder/dieharder-3.31.1-r1.ebuild
+++ b/app-crypt/dieharder/dieharder-3.31.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit autotools eutils
@@ -19,8 +19,27 @@ RDEPEND="sci-libs/gsl"
DEPEND="${RDEPEND}
doc? ( dev-tex/latex2html )"
+DOCS=(
+ NOTES
+)
+HTML_DOCS=()
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
+
+pkg_setup() {
+ use doc && DOCS+=(
+ ChangeLog
+ manual/dieharder.pdf manual/dieharder.ps
+ )
+ use doc && HTML_DOCS+=(
+ dieharder.html
+ )
+}
+
src_prepare() {
- epatch "${FILESDIR}/${P}-build.patch"
+ default
eautoreconf
}
@@ -31,15 +50,9 @@ src_compile() {
src_install() {
default
- dodoc NOTES
+
docinto "dieharder"
dodoc dieharder/README dieharder/NOTES
docinto "libdieharder"
dodoc libdieharder/README libdieharder/NOTES
-
- if use doc ; then
- dodoc ChangeLog dieharder.html
- docinto "manual"
- dodoc manual/dieharder.pdf manual/dieharder.ps
- fi
}