summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-18 20:18:20 +0100
committerUlrich Müller <ulm@gentoo.org>2022-08-19 00:24:43 +0200
commit424bd8ae7cbb3ce55e0567e8c9057d8d23c6cb57 (patch)
tree0e6d7082899670601add116b0d743baa71616dc0 /app-crypt/gnupg/gnupg-2.3.0.ebuild
parentdev-util/uglifyjs: Version bump to 3.17.0 (diff)
downloadgentoo-master.tar.gz
gentoo-master.tar.bz2
gentoo-master.zip
elisp-common.eclass: fix for Emacs 29 (explicitly require autoload)HEADmaster
Emacs 29's NEWS says: "The autoload.el library is now obsolete." We should therefore explicitly 'require it in order to have the eclass machinery work. Fix build failures with e.g. exec-path-from-shell, flycheck: ``` * Generating autoload file for GNU Emacs ... Error: void-function (batch-update-autoloads) debug-early-backtrace() debug-early(error (void-function batch-update-autoloads)) batch-update-autoloads() command-line-1(("--eval" "(setq make-backup-files nil)" "--eval" "(setq generated-autoload-file (expand-file-name \"exec-path-from-shell-autoloads.el\"))" "-f" "batch-update-autoloads" ".")) command-line() normal-top-level() Symbol’s function definition is void: batch-update-autoloads * elisp-make-autoload-file: batch-update-autoloads failed [ !! ] * ERROR: app-emacs/exec-path-from-shell-1.12::gentoo failed (compile phase): * (no error message) ``` See https://www.mail-archive.com/freebsd-pkg-fallout@freebsd.org/msg1982134.html and https://lists.gnu.org/archive/html/bug-gnu-emacs/2022-08/msg01259.html. Thanks-to: John Turner <jturner.usa+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-crypt/gnupg/gnupg-2.3.0.ebuild')
0 files changed, 0 insertions, 0 deletions