summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2015-09-10 09:05:56 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2015-09-10 09:07:06 +0300
commitde7b5bc60edf0e3746c89aafd8ed3f8cf7babff5 (patch)
tree1a32b78418edc33eb127d42295a749ff4dcd754f /app-crypt/gpgme
parentdev-libs/libgpg-error: version bump (diff)
downloadgentoo-de7b5bc60edf0e3746c89aafd8ed3f8cf7babff5.tar.gz
gentoo-de7b5bc60edf0e3746c89aafd8ed3f8cf7babff5.tar.bz2
gentoo-de7b5bc60edf0e3746c89aafd8ed3f8cf7babff5.zip
app-crypt/gpgme: version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-crypt/gpgme')
-rw-r--r--app-crypt/gpgme/Manifest1
-rw-r--r--app-crypt/gpgme/gpgme-1.6.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/gpgme/Manifest b/app-crypt/gpgme/Manifest
index 0dd3131e6b8c..7ea626ff4d44 100644
--- a/app-crypt/gpgme/Manifest
+++ b/app-crypt/gpgme/Manifest
@@ -1 +1,2 @@
DIST gpgme-1.5.5.tar.bz2 976383 SHA256 0b3d3d5107680c594777aae65882a1ff6dd1ba629a83432e719c8b82a743c207 SHA512 a01b84c1ae2a7c647b2de793fc05d39c4bf4a2d1b7378934e437857823f11ca9e9c1f3b32302d69a3a84d0be1fee1e1c86874355031b8fa6b40f4ad56ecc72ad WHIRLPOOL f3ad4282a254cf1ab8d01184df787a773fa7963a42157da93bee11430263fa86166f12f051e2b11d13be99ce1f0939d565cb02a8fba93ab6afed73ca7b2c0041
+DIST gpgme-1.6.0.tar.bz2 983573 SHA256 b09de4197ac280b102080e09eaec6211d081efff1963bf7821cf8f4f9916099d SHA512 b7ccccc2bac246b0759c8752cadd3e77f03da39711badfc66d0f21cefab3f3b07fe1038611ad9ca1c16a8a48d7e831dcca68d83d052456a4cf794a73e287d41b WHIRLPOOL 4e753156474097dba9db2905954d1754ca408066996a01cbc7266a24654eb7c2323043f40495cc3c227d8eef540eeca47de4c23bb329a2d34604d5a4d3828970
diff --git a/app-crypt/gpgme/gpgme-1.6.0.ebuild b/app-crypt/gpgme/gpgme-1.6.0.ebuild
new file mode 100644
index 000000000000..6c3378917863
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-1.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils libtool
+
+DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
+HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
+SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="1/11" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="common-lisp static-libs"
+
+DEPEND="app-crypt/gnupg
+ >=dev-libs/libassuan-2.0.2
+ >=dev-libs/libgpg-error-1.11"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.8-et_EE.patch
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --includedir="${EPREFIX}/usr/include/gpgme" \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ if ! use common-lisp; then
+ rm -fr "${ED}usr/share/common-lisp"
+ fi
+}