summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-09-02 00:02:59 -0400
committerZero_Chaos <zerochaos@gentoo.org>2016-09-02 00:02:59 -0400
commitb0c353930f14d040d685bb9c7df551fbd3506f39 (patch)
tree438530903d18d2dc78caa73367a0de8e9ca4bfb3 /app-crypt/hashcat
parentx11-libs/fltk: Clean up patches. (diff)
downloadgentoo-b0c353930f14d040d685bb9c7df551fbd3506f39.tar.gz
gentoo-b0c353930f14d040d685bb9c7df551fbd3506f39.tar.bz2
gentoo-b0c353930f14d040d685bb9c7df551fbd3506f39.zip
app-crypt/hashcat: import hashcat from pentoo overlay
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-crypt/hashcat')
-rw-r--r--app-crypt/hashcat/Manifest1
-rw-r--r--app-crypt/hashcat/hashcat-3.10-r1.ebuild48
-rw-r--r--app-crypt/hashcat/metadata.xml10
3 files changed, 59 insertions, 0 deletions
diff --git a/app-crypt/hashcat/Manifest b/app-crypt/hashcat/Manifest
new file mode 100644
index 000000000000..340f885e11d2
--- /dev/null
+++ b/app-crypt/hashcat/Manifest
@@ -0,0 +1 @@
+DIST hashcat-3.10.tar.gz 4077692 SHA256 3b555e5f7b35ab6a4558bc460f28d80b32f5a211bf9e08d6a1ba1bad5203e3e9 SHA512 2adf16513118b91085fe587c53b15f142abb7673f659b2721dcba8aacdac6f024b65e7b50b916f86c161c21e98eb4758f187d25ad1ca4c66cdb67a259b07ae04 WHIRLPOOL 64ea5b3491094b2578264675025d6438e9981d69b77376bffb2b02cdf4c1e2899a2f6585295d288197e84710a3802c105d17e392795aaa5a00a09c2eeaa4a50d
diff --git a/app-crypt/hashcat/hashcat-3.10-r1.ebuild b/app-crypt/hashcat/hashcat-3.10-r1.ebuild
new file mode 100644
index 000000000000..805aabf3b8e4
--- /dev/null
+++ b/app-crypt/hashcat/hashcat-3.10-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils pax-utils
+
+DESCRIPTION="An advanced CPU-based password recovery utility"
+HOMEPAGE="https://github.com/hashcat/hashcat"
+SRC_URI="https://github.com/hashcat/hashcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="video_cards_nvidia video_cards_fglrx"
+DEPEND="virtual/opencl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ #do not strip
+ sed -i "/CFLAGS_NATIVE += -s/d" src/Makefile || die
+ #do not add random CFLAGS
+ sed -i "s/-O2//" src/Makefile || die
+ export PREFIX=/usr
+}
+
+src_compile() {
+ default
+ pax-mark -mr hashcat
+}
+
+src_test() {
+ if use video_cards_nvidia; then
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
+ addwrite /dev/nvidia-uvm
+ if [ ! -w /dev/nvidia0 ]; then
+ einfo "To run these tests, portage likely must be in the video group."
+ einfo "Please run \"gpasswd -a portage video\" if the tests will fail"
+ fi
+ elif use vidia_cards_fglrx; then
+ addwrite /dev/ati
+ fi
+ #this always exits with 255 despite success
+ #./hashcat -b -m 2500 || die "Test failed"
+ ./hashcat -a 3 -m 1500 nQCk49SiErOgk
+}
diff --git a/app-crypt/hashcat/metadata.xml b/app-crypt/hashcat/metadata.xml
new file mode 100644
index 000000000000..f513208bf390
--- /dev/null
+++ b/app-crypt/hashcat/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>