summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2018-06-18 06:23:26 +0200
committerNicolas Bock <nicolasbock@gentoo.org>2018-06-18 06:30:01 +0200
commit22fc382893467a8f4a3a58db4e27b6d513bd98aa (patch)
tree3376a608948be4138744f5b06d5e51c961fa9ccd /app-crypt/kbfs
parentapp-crypt/keybase: Fix keybase-9999 (diff)
downloadgentoo-22fc382893467a8f4a3a58db4e27b6d513bd98aa.tar.gz
gentoo-22fc382893467a8f4a3a58db4e27b6d513bd98aa.tar.bz2
gentoo-22fc382893467a8f4a3a58db4e27b6d513bd98aa.zip
app-crypt/kbfs: Fix live ebuild
This change adds all of the features of kbfs-2.0.0 to the live ebuild. Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org> Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-crypt/kbfs')
-rw-r--r--app-crypt/kbfs/kbfs-9999.ebuild34
1 files changed, 15 insertions, 19 deletions
diff --git a/app-crypt/kbfs/kbfs-9999.ebuild b/app-crypt/kbfs/kbfs-9999.ebuild
index e3870b505ace..6c648020c5ec 100644
--- a/app-crypt/kbfs/kbfs-9999.ebuild
+++ b/app-crypt/kbfs/kbfs-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit git-r3 systemd
+inherit git-r3 golang-build systemd
DESCRIPTION="Keybase Filesystem (KBFS)"
HOMEPAGE="https://keybase.io/docs/kbfs"
@@ -14,37 +14,33 @@ SLOT="0"
KEYWORDS=""
IUSE="git"
-DEPEND=">=dev-lang/go-1.6:0"
+DEPEND=""
RDEPEND="
app-crypt/gnupg
sys-fs/fuse
"
-S="${WORKDIR}/src/github.com/keybase/kbfs"
-
src_unpack() {
git-r3_src_unpack
- mkdir -p "$(dirname "${S}")" || die
- ln -s "${WORKDIR}/${P}" "${S}" || die
+ mkdir -vp "${S}/src/github.com/keybase" || die
+ ln -vs "${S}" "${S}/src/github.com/keybase/kbfs" || die
}
src_compile() {
- GOPATH="${WORKDIR}" \
- go build -v -x \
- -tags production \
- -o "${T}/kbfsfuse" \
- github.com/keybase/kbfs/kbfsfuse
- use git && \
- GOPATH="${WORKDIR}" \
- go build -v -x \
- -tags production \
- -o "${T}/git-remote-keybase" \
- github.com/keybase/kbfs/kbfsgit/git-remote-keybase
+ EGO_PN="github.com/keybase/kbfs/kbfsfuse" \
+ EGO_BUILD_FLAGS="-tags production -o ${T}/kbfsfuse" \
+ golang-build_src_compile
+ EGO_PN="github.com/keybase/kbfs/kbfsgit/git-remote-keybase" \
+ EGO_BUILD_FLAGS="-tags production -o ${T}/git-remote-keybase" \
+ golang-build_src_compile
+ EGO_PN="github.com/keybase/kbfs/redirector" \
+ EGO_BUILD_FLAGS="-tags production -o ${T}/keybase-redirector" \
+ golang-build_src_compile
}
src_install() {
dobin "${T}/kbfsfuse"
- use git && \
- dobin "${T}/git-remote-keybase"
+ dobin "${T}/git-remote-keybase"
+ dobin "${T}/keybase-redirector"
systemd_douserunit "${S}/packaging/linux/systemd/kbfs.service"
}