summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2018-02-23 15:01:01 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2018-02-23 15:01:20 -0700
commit1303d32d0e940363dbb1ca6b8291cf5cb59dd674 (patch)
tree450e144a566271f23544ffd1737a92ec7bd65bac /app-crypt/keybase
parentmedia-libs/plib: Rev bump to bump EAPI to EAPI=6 (diff)
downloadgentoo-1303d32d0e940363dbb1ca6b8291cf5cb59dd674.tar.gz
gentoo-1303d32d0e940363dbb1ca6b8291cf5cb59dd674.tar.bz2
gentoo-1303d32d0e940363dbb1ca6b8291cf5cb59dd674.zip
app-crypt/keybase: Update live ebuild
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-crypt/keybase')
-rw-r--r--app-crypt/keybase/keybase-9999.ebuild21
1 files changed, 18 insertions, 3 deletions
diff --git a/app-crypt/keybase/keybase-9999.ebuild b/app-crypt/keybase/keybase-9999.ebuild
index 09718d4794cd..05206f40c35b 100644
--- a/app-crypt/keybase/keybase-9999.ebuild
+++ b/app-crypt/keybase/keybase-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils versionator git-r3
+inherit eutils systemd user versionator git-r3
MY_PV=$(replace_version_separator 3 '-')
@@ -17,12 +17,17 @@ KEYWORDS=""
IUSE=""
DEPEND="
- >=dev-lang/go-1.6:0"
+ >=dev-lang/go-1.6:0
+ app-crypt/kbfs"
RDEPEND="
app-crypt/gnupg"
S="${WORKDIR}/src/github.com/keybase/client"
+pkg_setup() {
+ enewuser keybasehelper
+}
+
src_unpack() {
git-r3_src_unpack
mkdir -p "$(dirname "${S}")" || die
@@ -35,13 +40,23 @@ src_compile() {
-tags production \
-o "${T}/keybase" \
github.com/keybase/client/go/keybase || die
+ GOPATH="${WORKDIR}" \
+ go build -v -x \
+ -tags production \
+ -o "${T}/keybase-mount-helper" \
+ github.com/keybase/client/go/mounter/keybase-mount-helper || die
}
src_install() {
dobin "${T}/keybase"
+ dobin "${T}/keybase-mount-helper"
+ fowners keybasehelper:keybasehelper "${EROOT}/usr/bin/keybase-mount-helper"
+ dobin "${S}/packaging/linux/run_keybase"
+ systemd_douserunit "${S}/packaging/linux/systemd/keybase.service"
}
pkg_postinst() {
elog "Run the service: keybase service"
elog "Run the client: keybase login"
+ elog "Restart keybase: run_keybase"
}