summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKalin KOZHUHAROV <me.kalin@gmail.com>2018-04-22 20:25:49 +0200
committerNicolas Bock <nicolasbock@gentoo.org>2018-06-08 18:28:42 +0200
commitdca7213484e7f7608dd4e52445b4401ff2593ee0 (patch)
tree1b38a939260e0000a2d58fcb1d01219bd51ae907 /app-crypt/keybase
parentdev-util/shards: drop old (diff)
downloadgentoo-dca7213484e7f7608dd4e52445b4401ff2593ee0.tar.gz
gentoo-dca7213484e7f7608dd4e52445b4401ff2593ee0.tar.bz2
gentoo-dca7213484e7f7608dd4e52445b4401ff2593ee0.zip
app-crypt/keybase: fixing non-working KBFS
KBFS needs SUID and some other tweaks Fixing BGO bug #649634 ... Updating both 1.0.44 and 9999 with the same logic. This is a rework for https://github.com/gentoo/gentoo/pull/7370/ due to (my) flowed git workflow... See the comments there. Closes: https://bugs.gentoo.org/649634 Reported-by: Kalin KOZHUHAROV <kalin@thinrope.net>
Diffstat (limited to 'app-crypt/keybase')
-rw-r--r--app-crypt/keybase/keybase-1.0.44.ebuild8
-rw-r--r--app-crypt/keybase/keybase-9999.ebuild8
2 files changed, 12 insertions, 4 deletions
diff --git a/app-crypt/keybase/keybase-1.0.44.ebuild b/app-crypt/keybase/keybase-1.0.44.ebuild
index afb357189ce5..505b2ca3eb20 100644
--- a/app-crypt/keybase/keybase-1.0.44.ebuild
+++ b/app-crypt/keybase/keybase-1.0.44.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/keybase/client/archive/v${MY_PV}.tar.gz -> ${P}.tar.
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="+suid"
DEPEND="
>=dev-lang/go-1.6:0
@@ -49,8 +49,12 @@ src_compile() {
src_install() {
dobin "${T}/keybase"
+ dodir "/var/lib/keybase"
+ fowners keybasehelper:keybasehelper "/var/lib/keybase"
+ dosym "/tmp/keybase" "/var/lib/keybase/mount1"
dobin "${T}/keybase-mount-helper"
- fowners keybasehelper:keybasehelper "${EROOT}/usr/bin/keybase-mount-helper"
+ fowners keybasehelper:keybasehelper "/usr/bin/keybase-mount-helper"
+ use suid && fperms 4755 "/usr/bin/keybase-mount-helper"
dobin "${S}/packaging/linux/run_keybase"
systemd_douserunit "${S}/packaging/linux/systemd/keybase.service"
}
diff --git a/app-crypt/keybase/keybase-9999.ebuild b/app-crypt/keybase/keybase-9999.ebuild
index 05206f40c35b..181e16cb154b 100644
--- a/app-crypt/keybase/keybase-9999.ebuild
+++ b/app-crypt/keybase/keybase-9999.ebuild
@@ -14,7 +14,7 @@ EGIT_REPO_URI="https://github.com/keybase/client.git"
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="+suid"
DEPEND="
>=dev-lang/go-1.6:0
@@ -49,8 +49,12 @@ src_compile() {
src_install() {
dobin "${T}/keybase"
+ dodir "/var/lib/keybase"
+ fowners keybasehelper:keybasehelper "/var/lib/keybase"
+ dosym "/tmp/keybase" "/var/lib/keybase/mount1"
dobin "${T}/keybase-mount-helper"
- fowners keybasehelper:keybasehelper "${EROOT}/usr/bin/keybase-mount-helper"
+ fowners keybasehelper:keybasehelper "/usr/bin/keybase-mount-helper"
+ use suid && fperms 4755 "/usr/bin/keybase-mount-helper"
dobin "${S}/packaging/linux/run_keybase"
systemd_douserunit "${S}/packaging/linux/systemd/keybase.service"
}