summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-09-20 11:27:41 +0200
committerMarek Szuba <marecki@gentoo.org>2021-09-20 11:27:41 +0200
commit660b9e06ad0a8b8f6a49044d507fa1cbecb1ed1c (patch)
tree53b7120be02f31c83fe3394c865c6299d4e12d35 /app-crypt/libu2f-server/libu2f-server-1.1.0-r2.ebuild
parentx11-misc/xdotool: stabilize 3.20210804.2 for amd64 (diff)
downloadgentoo-660b9e06ad0a8b8f6a49044d507fa1cbecb1ed1c.tar.gz
gentoo-660b9e06ad0a8b8f6a49044d507fa1cbecb1ed1c.tar.bz2
gentoo-660b9e06ad0a8b8f6a49044d507fa1cbecb1ed1c.zip
app-crypt/libu2f-server: update EAPI 7 -> 8
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-crypt/libu2f-server/libu2f-server-1.1.0-r2.ebuild')
-rw-r--r--app-crypt/libu2f-server/libu2f-server-1.1.0-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-crypt/libu2f-server/libu2f-server-1.1.0-r2.ebuild b/app-crypt/libu2f-server/libu2f-server-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..2141848a479b
--- /dev/null
+++ b/app-crypt/libu2f-server/libu2f-server-1.1.0-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Yubico Universal 2nd Factor (U2F) server C Library"
+HOMEPAGE="https://developers.yubico.com/libu2f-server/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0/0.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/openssl:0=[${MULTILIB_USEDEP}]
+ dev-libs/hidapi[${MULTILIB_USEDEP}]
+ dev-libs/json-c:=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check[${MULTILIB_USEDEP}] )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.0-disable-help2man-gengetopt-checks.patch"
+ "${FILESDIR}/${PN}-1.1.0-jsonc014.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+ touch man/u2f-server.1 || die # do not rebuild the man page
+}
+
+multilib_src_configure() {
+ myeconfargs=(
+ --disable-h2a # tarball already contains the manpage
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}