summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSalah Coronya <salah.coronya@gmail.com>2020-05-13 22:12:06 -0500
committerJason A. Donenfeld <zx2c4@gentoo.org>2020-05-17 22:59:51 -0600
commit911b35667b9e66b5d29f0ef2927219cacabd2e30 (patch)
treecb39742d9f54a948818caed5d1bc342f601296f4 /app-crypt/tpm2-tss
parentdev-python/warlock: 1.3.3 bump (diff)
downloadgentoo-911b35667b9e66b5d29f0ef2927219cacabd2e30.tar.gz
gentoo-911b35667b9e66b5d29f0ef2927219cacabd2e30.tar.bz2
gentoo-911b35667b9e66b5d29f0ef2927219cacabd2e30.zip
app-crypt/tpm2-tss: Fix sandbox violation for systemd users
Closes: https://bugs.gentoo.org/722864 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Salah Coronya <salah.coronya@gmail.com> Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'app-crypt/tpm2-tss')
-rw-r--r--app-crypt/tpm2-tss/files/tpm2-tss-2.4.0-Dont-run-systemd-sysusers-in-Makefile.patch15
-rw-r--r--app-crypt/tpm2-tss/tpm2-tss-2.4.0.ebuild5
2 files changed, 18 insertions, 2 deletions
diff --git a/app-crypt/tpm2-tss/files/tpm2-tss-2.4.0-Dont-run-systemd-sysusers-in-Makefile.patch b/app-crypt/tpm2-tss/files/tpm2-tss-2.4.0-Dont-run-systemd-sysusers-in-Makefile.patch
new file mode 100644
index 000000000000..c916bbf0133c
--- /dev/null
+++ b/app-crypt/tpm2-tss/files/tpm2-tss-2.4.0-Dont-run-systemd-sysusers-in-Makefile.patch
@@ -0,0 +1,15 @@
+diff --git a/Makefile.am b/Makefile.am
+index c543a287..58187f7e 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -558,10 +558,6 @@ uninstall-local:
+ -rm $(DESTDIR)$(udevrulesdir)/$(udevrulesprefix)tpm-udev.rules
+ endif
+
+-# Create tss user and FAPI directories directly after installation (vs. after a reboot)
+-install-exec-hook:
+- systemd-sysusers && systemd-tmpfiles --create || true
+-
+ uninstall-hook:
+ cd $(DESTDIR)$(man3dir) && \
+ [ -L Tss2_TctiLdr_Initialize_Ex.3 ] && \
diff --git a/app-crypt/tpm2-tss/tpm2-tss-2.4.0.ebuild b/app-crypt/tpm2-tss/tpm2-tss-2.4.0.ebuild
index f8986d88dc98..76c8cc9bf6d0 100644
--- a/app-crypt/tpm2-tss/tpm2-tss-2.4.0.ebuild
+++ b/app-crypt/tpm2-tss/tpm2-tss-2.4.0.ebuild
@@ -34,7 +34,8 @@ BDEPEND="virtual/pkgconfig
PATCHES=(
"${FILESDIR}/${PN}-2.4.0-fix-tmpfiles-path.patch"
-)
+ "${FILESDIR}/${PN}-2.4.0-Dont-run-systemd-sysusers-in-Makefile.patch"
+ )
pkg_setup() {
local CONFIG_CHECK=" \
@@ -57,7 +58,7 @@ src_configure() {
--with-runstatedir=/run \
--with-udevrulesdir="$(get_udevdir)/rules.d" \
--with-udevrulesprefix=60- \
- --with-sysusersdir="/usr/lib/sysusers.d"
+ --with-sysusersdir="/usr/lib/sysusers.d" \
--with-tmpfilesdir="/usr/lib/tmpfiles.d"
}